Opened 10 years ago

Last modified 9 years ago

#1571 closed defect (duplicate)

[bug] SIGFPE av_frac_add at utils.c:88

Reported by: jojelino@… Owned by: reimar
Priority: normal Component: core
Version: unspecified Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

debug infomation follows


gdb mencoder
set args -odml stream2.mpg -o 702006852.avi -of lavf -ffourcc H264 -ovc x264 -oac copy -vfm ffmpeg -vf crop=1920:1080:0:0,scale=1280:-3:1:arnd=1,pp=lb,expand=1280:720 -x264encopts crf=26:pass=1:turbo=1:qp_min=26:qp_max=51:bframes=4:ref=1:8x8dct:b_pyramid:direct_pred=temporal:weight_b:me=dia:partitions=none:8x8dct:subq=2:mixed_refs:deadzone_inter=8:deadzone_intra=16:nodct_decimate:log=0:trellis=2:threads=4 -msglevel all=9 -passlogfile 702006852.log
=================================================================
DEMUX: Append packet to d_audio, len=1536 pts=43470.231 pos=1277952 [packs: A
=1 V=10]
ds_fill_buffer(d_video) called
vd_ffmpeg data: 10000, db4e1c00, 10000b8, 5b5787b5
Pos: 0.0s 1f ( 0%) 0fps Trem: 0min 0mb A-V:0.000 [0:0] A/Vms 1/0 D
ds_fill_buffer(d_video) called
vd_ffmpeg data: 10000, b475c00, 10000b8, 5b5787b5

1 duplicate frame(s)!
Muxer frame buffer sending 17 frame(s) to the muxer.
VIDEO CODEC ID: 28
MUXER_LAVF(video stream) width:0, height:0, bit_rate:800000, time_base.den:30000
, time_base.num:1001, block_size:0
AUDIO CODEC ID: 15003, TAG: 0
MUXER_LAVF(audio stream) frame_size: 1536, scale: 4, sps: 48000, rate: 125, ctx-

block_align = stream->wf->nBlockAlign; 0=1 stream->wf->nAvgBytesPerSec:46969

W>block_align = stream->wf->nBlockAlign; 0=1 stream->wf->nAvgBytesPerSec:46969
Writing header...
[avi @ 0xb42038]dimensions not set

Program received signal SIGFPE, Arithmetic exception.
0x00a1e8c5 in divdi3 (u=138240000, v=0)

at ../.././libgcc/../gcc/libgcc2.c:895

895 d0 = 1 / d0; /* Divide intentionally by zero. */
(gdb) bt
#0 0x00a1e8c5 in divdi3 (u=138240000, v=0)

at ../.././libgcc/../gcc/libgcc2.c:895

#1 0x00000000 in ?? ()
(gdb)
Single stepping until exit from function ntdllLdrEnumerateLoadedModules,
which has no line number information.
0x7c971567 in ntdllRtlTimeFieldsToTime ()

from /cygdrive/f/WINDOWS/system32/ntdll.dll

(gdb) bt
#0 0x7c971567 in ntdllRtlTimeFieldsToTime ()

from /cygdrive/f/WINDOWS/system32/ntdll.dll

#1 0x005a6680 in av_frac_add (f=0x0, incr=<value optimized out>)

at utils.c:88

#2 0x005a7fe1 in compute_pkt_fields2 (st=0x1057c420,

pkt=<value optimized out>) at utils.c:708

#3 0x005ac66b in av_interleaved_write_frame (s=<value optimized out>,

pkt=<value optimized out>) at utils.c:708

#4 0x00414ada in write_chunk (stream=<value optimized out>,

len=<value optimized out>, flags=<value optimized out>,
dts=<value optimized out>, pts=<value optimized out>)
at libmpdemux/muxer_lavf.c:193

#5 0x0040937c in muxer_write_chunk (s=0x1057c348, len=<value optimized out>,

flags=<value optimized out>, dts=<value optimized out>,
pts=<value optimized out>) at libmpdemux/muxer.c:76

#6 0x004048b4 in main (argc=<value optimized out>,

argv=<value optimized out>) at mencoder.c:1583

==========================================================================
MUXER_LAVF(video stream) width:0, height:0, bit_rate:800000, time_base.den:30000
, time_base.num:1001, block_size:0

I used lavf demuxer(MPEG2-TS) and mux it(LAVF-AVI)

and width and height of video_stream is ZERO
'[avi @ 0xb42038]dimensions not set ' came out consequently.
i think it might be caused by following.

  1. hard-coded core(mencoder)/eg, it can't deliver stream_t between demuxer and muxer properly. finally it brokes entire program.
  2. it's not problem of mencoder. ask for ffmpeg_devel :)

if i had enough time, i can gather more information but that's all.

Change History (1)

comment:1 Changed 9 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed, patriotact@gmail.com

same gdb so i merge these bugs.
and bug 1337 has a patch even.

Note: See TracTickets for help on using tickets.