Opened 10 years ago

Last modified 8 years ago

#1575 closed defect (fixed)

No sound on a clip that plays perfectly in VLC and ffplay

Reported by: arrenlex@… Owned by: reimar
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc: reimar, compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The clip linked in the URL was recorded from mythtv. It comes from a hardware encoder -- the WinTV HVR 1900.

It plays perfectly in VLC and ffplay, but mplayer produces no sound. The output looks like this (the movie that produces this output is a longer version of the same clip, I simply cut the one I linked to to 10 MB with head -c):

em@sam:~$ mplayer -v -frames 1 1042_20090620220420.mpg
MPlayer SVN-r29699-4.3.2 (C) 2000-2009 MPlayer Team
CPU vendor name: AuthenticAMD max cpuid level: 1
CPU: Dual Core AMD Opteron(tm) Processor 180 (Family: 15, Model: 35, Stepping: 2)
extended cpuid-level: 24
extended cache-info: 67141952
Detected cache-line size is 64 bytes
Testing OS support for SSE... yes.
Tests of OS support for SSE passed.
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNowExt: 1 SSE: 1 SSE2: 1 SSSE3: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowExt SSE SSE2 CMOV
get_path('codecs.conf') -> '/home/em/.mplayer/codecs.conf'
Reading /home/em/.mplayer/codecs.conf: Can't open '/home/em/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/codecs.conf': No such file or directory
Using built-in default codecs.conf.
Configuration:
CommandLine?: '-v' '-frames' '1' '1042_20090620220420.mpg'
init_freetype
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
get_path('fonts') -> '/home/em/.mplayer/fonts'
Using nanosleep() timing
get_path('input.conf') -> '/home/em/.mplayer/input.conf'
Can't open input config file /home/em/.mplayer/input.conf: No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or directory
Falling back on default (hardcoded) input config
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
get_path('1042_20090620220420.mpg.conf') -> '/home/em/.mplayer/1042_20090620220420.mpg.conf'

Playing 1042_20090620220420.mpg.
get_path('sub/') -> '/home/em/.mplayer/sub/'
[file] File size is 1005146112 bytes
STREAM: [file] 1042_20090620220420.mpg
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
LAVF_check: MPEG-PS format
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename 1042_20090620220420.mpg ext: .mpg
Checking for Nullsoft Streaming Video
Checking for MOV
Checking for VIVO
header block 1 size: 0
AVS: avs_check_file - attempting to open file 1042_20090620220420.mpg
AVS: File is too big, aborting...
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 71375, FOUND 47, packet_size= 0, SEEMS A TS? 0
Checking for LMLM4 Stream Format
Invalid packet in LMLM4 stream: ch=0 size=1141171444
LMLM4 Stream Format not found
system stream synced at 0xD (13)!
==> Found video stream: 0
==> Found audio stream: 0
MPEG-PS file format detected.
Searching for sequence header... OK!
VIDEO: MPEG2 720x480 (aspect 2) 29.970 fps 6000.0 kbps (750.0 kbyte/s)
[V] filefmt:2 fourcc:0x10000002 size:720x480 fps:29.970 ftime:=0.0334
get_path('sub/') -> '/home/em/.mplayer/sub/'
X11 opening display: :0.0
vo: X11 color mask: FFFFFF (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1680x1050 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Detected wm supports NetWM.
[x11] Detected wm supports FULLSCREEN state.
[x11] Detected wm supports ABOVE state.
[x11] Detected wm supports BELOW state.
[x11] Detected wm supports STAYS_ON_TOP state.
[x11] Current fstype setting honours FULLSCREEN STAYS_ON_TOP ABOVE BELOW X atoms
[VO_XV] Using Xv Adapter #0 (NV17 Video Texture)
[xv common] Drawing no colorkey.
[xv common] Maximum source image dimensions: 2046x2046
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred colorspace: Mpeg PES)
Trying filter chain: vo
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
SwScale? params: -1 x -1 (-1=no scaling)
Trying filter chain: scale vo
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat? -1
INFO: libavcodec init OK!
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
dec_audio: Allocating 4608 + 65536 = 70144 bytes for output buffer.
mp3lib: using 3DNow!Ex optimized decore!
MP3lib: init layer2&3 finished, tables done

Too many video packets in the buffer: (4096 in 7867228 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
ds_fill_buffer: EOF reached (stream: audio)
ADecoder init failed :(
ADecoder init failed :(
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
dec_audio: Allocating 192000 + 65536 = 257536 bytes for output buffer.
FFmpeg's libavcodec audio codec
INFO: libavcodec init OK!

Too many video packets in the buffer: (4096 in 7867228 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
ds_fill_buffer: EOF reached (stream: audio)

Too many video packets in the buffer: (4096 in 7867228 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
ds_fill_buffer: EOF reached (stream: audio)

Too many video packets in the buffer: (4096 in 7867228 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
ds_fill_buffer: EOF reached (stream: audio)

Too many video packets in the buffer: (4096 in 7867228 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
ds_fill_buffer: EOF reached (stream: audio)

Too many video packets in the buffer: (4096 in 7867228 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
ds_fill_buffer: EOF reached (stream: audio)

Too many video packets in the buffer: (4096 in 7867228 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
ds_fill_buffer: EOF reached (stream: audio)
Unknown/missing audio format -> no sound
Uninit audio: ffmpeg
ADecoder init failed :(
Opening audio decoder: [libmad] libmad mpeg audio decoder
dec_audio: Allocating 4096 bytes for input buffer.
dec_audio: Allocating 9216 + 65536 = 74752 bytes for output buffer.

Too many video packets in the buffer: (4096 in 7867228 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
ds_fill_buffer: EOF reached (stream: audio)
Cannot sync MAD frame
ADecoder init failed :(
ADecoder init failed :(
Opening audio decoder: [hwmpa] MPEG audio pass-through (fake decoder)
dec_audio: Allocating 4608 bytes for input buffer.
dec_audio: Allocating 4608 + 65536 = 70144 bytes for output buffer.

Too many video packets in the buffer: (4096 in 7867228 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
ds_fill_buffer: EOF reached (stream: audio)
Cannot sync MPA frame: 0
ADecoder init failed :(
ADecoder init failed :(
Cannot find codec for audio format 0x50.
Audio: no sound
Freeing 0 unused audio chunks.
Starting playback...
[ffmpeg] aspect_ratio: 1.333333
VDec: vo config request - 720 x 480 (preferred colorspace: Planar YV12)
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO Config (720x480->720x540,flags=5,'MPlayer',0x32315659)
VO: [xv] 720x480 => 720x540 Planar YV12 [fs] [zoom]
VO: Description: X11/Xv
VO: Author: Gerd Knorr <kraxel@…> and others
Xvideo image format: 0x32595559 (YUY2) packed
Xvideo image format: 0x32315659 (YV12) planar
Xvideo image format: 0x59565955 (UYVY) packed
Xvideo image format: 0x30323449 (I420) planar
using Xvideo port 499 for hw scaling
* [vo] Allocating (slices) mp_image_t, 720x480x12bpp YUV planar, 518400 bytes
* [vo] Allocating (slices) mp_image_t, 720x480x12bpp YUV planar, 518400 bytes
Unicode font: 4929 glyphs.
Unicode font: 4929 glyphs.
EOF code: 1 4 ??% ??% ??,?% 0 0

Uninit video: ffmpeg
vo: uninit ...

Exiting... (End of file)
em@sam:~$

Change History (5)

comment:1 Changed 10 years ago by compn

reproduced.

works with mplayer -ss 3 -demuxer lavf

comment:2 Changed 10 years ago by reimar

The problem is in mp3lib, e.g. -ac ffmp2 works, too.

comment:3 Changed 10 years ago by reimar

  • Cc Reimar.Doeffinger@… added

comment:4 Changed 9 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:5 Changed 8 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed, patriotact@gmail.com

mp3lib is now marked buggy, meaning ff decoders are higher priority. closing bug...

Note: See TracTickets for help on using tickets.