Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#159 closed defect (fixed)

Crash Nero Digital AVC

Reported by: x-files@… Owned by: alex@…
Priority: important Component: core
Version: HEAD Severity: normal
Keywords: Cc: diego@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I upload sample file @
ftp://ftp.mplayerhq.hu/MPlayer/incoming/nerodigitalAVC/
For more info about format --> http://www.nero.com/en/632213330526628.html

MPlayer dev-CVS-041206-18:22-3.3.1 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices Athlon Thunderbird (Family: 6, Stepping: 2) Detected
cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0 Compiled for x86 CPU
with extensions: MMX MMX2 3DNow 3DNowEx

66 audio & 170 video codecs
CommandLine?: 'x:\Samples\NeroAVC.mp4' '-v' '10'
init_freetype
c:/windows/fonts/arial.ttf doesn't look like a font description, ignoring.
Cannot load font: c:/windows/fonts/arial.ttf Using MMX (with tiny bit MMX2)
Optimized OnScreenDisplay? Using Windows native timing
get_path('input.conf') -> 'X:/Programas
Genericos/Mplayer?/winmplayer/mplayer/mpl
ayer/input.conf'
Parsing input config file X:/Programas
Genericos/Mplayer?/winmplayer/mplayer/mpla
yer/input.conf
Input config file X:/Programas
Genericos/Mplayer?/winmplayer/mplayer/mplayer/inpu
t.conf parsed: 59 binds
get_path('x:\Samples\NeroAVC.mp4.conf') -> 'X:/Programas Genericos/Mplayer?/winmp
layer/mplayer/mplayer/x:\Samples\NeroAVC.mp4.conf'
Playing x:\Samples\NeroAVC.mp4.
WINSOCK2 init: 0
[file] File size is 6766583 bytes
STREAM: [file] x:\Samples\NeroAVC.mp4
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi) Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for Nullsoft Streaming Video
Checking for NuppelVideo?
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename x:\Samples\NeroAVC.mp4 ext: .mp4 Trying
demuxer 7 based on filename extension Checking for MOV
ISO: Unknown File Type Major Brand: avc1
ISO: File Type Minor Version: 0
ISO: File Type Compatible Brand #0: avc1
ISO: File Type Compatible Brand #1: isom
ISO: File Type Compatible Brand #2: ndxs
MOV: Movie DATA found!
MOV: Movie header found!
QuickTime?/MOV file format detected.
MOV: Movie header (100 bytes): tscale=1000 dur=32120
MOV: unknown chunk: iods 31


MOV: Track #0:
MOV: unknown chunk: tref 16
MOV: Media stream!
MOV: Handler header: /odsm ()
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Generic header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4s (41 bytes)
MOV: Sample duration table! (1 blocks)
Warning! pts=1 length=0
MOV: Sample->Chunk mapping table! (1 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=1 ss=28) (ver:0,flags:0)
MOV: Chunk offset table! (1 chunks)
MOV: Media header!
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=1 dur=1 lay=0 vol=0 MOV track #0: 1 chunks, 0 samples
pts=1 scale=1000 time=0.001
Generic track - not completely understood! (id: 0)


MOV: Track #1:
MOV: Media stream!
MOV: Handler header: /sdsm ()
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Generic header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4s (51 bytes)
MOV: Sample duration table! (1 blocks)
Warning! pts=1 length=0
MOV: Sample->Chunk mapping table! (1 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=1 ss=30) (ver:0,flags:0)
MOV: Chunk offset table! (1 chunks)
MOV: Media header!
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=2 dur=1 lay=0 vol=0 MOV track #1: 1 chunks, 0 samples
pts=1 scale=1000 time=0.001
Generic track - not completely understood! (id: 1)


MOV: Track #2:
MOV: Media stream!
MOV: Handler header: /vide () VC video
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Video header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: avc1 (135 bytes)
MOV: Sample duration table! (1 blocks)
Warning! pts=803000 length=0
MOV: Sample->Chunk mapping table! (100 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=803 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (750 chunks)
MOV: Syncing samples (keyframes) table! (10 entries) (ver:0,flags:0)
MOV: unknown chunk: ctts 4936
MOV: Media header!
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=3 dur=32120 lay=0 vol=0 MOV track #2: 750 chunks,
803 samples pts=803000 scale=25000 time=32.120 ==> Found video stream: 2
MOV: AVC decoder configuration record atom (45)!
MOV: avcC version: 1
MOV: avcC profile: 77
MOV: avcC profile compatibility: 0
MOV: avcC level: 40
MOV: avcC nal length size: 4
MOV: avcC number of sequence param sets: 1
MOV: avcC sps 0 have length 22
MOV: avcC number of picture param sets: 1
MOV: avcC pps 0 have length 4
MOV: Found unknown movie atom btrt (20)!
Image size: 720 x 576 (24 bpp)
Display size: 720 x 576
Fourcc: avc1 Codec: 'AVC Coding'


MOV: Track #3:
MOV: Media stream!
MOV: Handler header: /soun ()
MOV: unknown handler class: 0x0 ()
MOV: Media info!
MOV: Sound header!
MOV: unknown chunk: dinf 28
MOV: Sample info!
MOV: Description list! (cnt:1)
MOV: desc #0: mp4a (70 bytes)
MOV: Sample duration table! (1 blocks)
Warning! pts=766976 length=0
MOV: Sample->Chunk mapping table! (1 blocks) (ver:0,flags:0)
MOV: Sample size table! (entries=749 ss=0) (ver:0,flags:0)
MOV: Chunk offset table! (749 chunks)
MOV: Media header!
MOV: Track header!
tkhd len=84 ver=0 flags=0x0 id=4 dur=31957 lay=0 vol=256 MOV track #3: 749
chunks, 749 samples
pts=766976 scale=24000 time=31.957
==> Found audio stream: 3
Audio bits: 0 chans: 2 rate: 24000
MOV: Found MPEG4 audio Elementary Stream Descriptor atom (50)!
ESDS MPEG4 version: 0 flags: 0x000000
ESDS MPEG4 ES Descriptor (34Bytes):

-> ESId: 0
-> streamPriority: 0

ESDS MPEG4 Decoder Config Descriptor (22Bytes):

-> objectTypeId: 64
-> streamType: 0x15
-> bufferSizeDB: 0x0005D5
-> maxBitrate: 187.672kbit/s
-> avgBitrate: 63.912kbit/s

ESDS MPEG4 Decoder Specific Descriptor (5Bytes) ESDS MPEG4 Sync Layer Config
Descriptor (1Bytes) -> predefined: 2
Fourcc: mp4a


Quicktime Clip Info:
MOV: longest streams: A: #3 (749 samples) V: #2 (803 samples)
VIDEO: [avc1] 720x576 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:7 fourcc:0x31637661 size:720x576 fps:25.00 ftime:=0.0400
get_path('sub/') -> 'X:/Programas
Genericos/Mplayer?/winmplayer/mplayer/mplayer/s
ub/'
get_path('default.sub') -> 'X:/Programas Genericos/Mplayer?/winmplayer/mplayer/mp
layer/default.sub'
==========================================================================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
dec_audio: Allocating 4608 bytes for input buffer.
dec_audio: Allocating 49152 + 65536 = 114688 bytes for output buffer.
FAAD: Decoder init done (0Bytes)!
FAAD: Negotiated samplerate: 48000Hz channels: 2
FAAD: got 63kbit/s bitrate from MP4 header!
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 7989->192000 (63.9 kbit) Selected
audio codec: [faad] afm:faad (FAAD AAC (MPEG2/MPEG4 Audio) decoder)
==========================================================================
<vo_directx><INFO>checking primary surface <vo_directx><FORMAT PRIMARY>13 BGR32
supported <vo_directx><INFO>testing supported overlay pixelformats
<vo_directx><FORMAT OVERLAY>0 YV12 supported <vo_directx><FORMAT OVERLAY>1 I420

not supported <vo_directx><FORMAT OVERLAY>2 IYUV not supported

<vo_directx><FORMAT OVERLAY>3 YVU9 supported <vo_directx><FORMAT OVERLAY>4 YUY2

supported <vo_directx><FORMAT OVERLAY>5 UYVY supported <vo_directx><FORMAT

OVERLAY>6 RGB15 not supported <vo_directx><FORMAT OVERLAY>7 BGR15 not supported
<vo_directx><FORMAT OVERLAY>8 RGB16 not supported <vo_directx><FORMAT OVERLAY>9
BGR16 not supported <vo_directx><FORMAT OVERLAY>10 RGB24 not supported
<vo_directx><FORMAT OVERLAY>11 BGR24 not supported <vo_directx><FORMAT
OVERLAY>12 RGB32 not supported <vo_directx><FORMAT OVERLAY>13 BGR32 not
supported <vo_directx><INFO>Your card supports 4 of 14 overlayformats
<vo_directx><INFO>can mirror up down <vo_directx><INFO>hardware supports overlay
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
INFO: libavcodec init OK!
Selected video codec: [ffh264] vfm:ffmpeg (FFmpeg H.264)
==========================================================================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
[libaf] Adding filter dummy
[dummy] Was reinitialized, rate=48000Hz, nch = 2, format = 0x00000001 and bps =
2
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
ao_win32: Samplerate:48000Hz Channels:2 Format:Signed 16-bit (Little-Endian)
ao_win32: Buffersize:4096
AO: [win32] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
AO: Description: Windows waveOut audio output
AO: Author: Sascha Sommer <saschasommer@…> Building audio filter chain
for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
[dummy] Was reinitialized, rate=48000Hz, nch = 2, format = 0x00000001 and bps =
2
[dummy] Was reinitialized, rate=48000Hz, nch = 2, format = 0x00000001 and bps =
2
Starting playback...
[ffmpeg] aspect_ratio: 1.250000
VDec: vo config request - 720 x 576 (preferred csp: Planar YV12) Trying filter
chain: vo
VDec: using Planar YV12 as output csp (no 0) Movie-Aspect is 1.25:1 - prescaling
to correct movie aspect.
VO Config (720x576->720x576,flags=0,'MPlayer',0x32315659)
VO: [directx] 720x576 => 720x576 Planar YV12
VO: Description: Directx DDraw YUV/RGB/BGR renderer
VO: Author: Sascha Sommer <saschasommer@…> <vo_directx><INFO>overlay
with format YV12 created
* [vo] Exporting mp_image_t, 720x576x12bpp YUV planar, 622080 bytes Unicode
font: 1418 glyphs.
[h264 @ 009A53F0]illegal short term buffer state detected
[h264 @ 009A53F0]illegal short term buffer state detected
[h264 @ 009A53F0]illegal short term buffer state detected
[h264 @ 009A53F0]illegal short term buffer state detected
[h264 @ 009A53F0]illegal short term buffer state detected
[h264 @ 009A53F0]illegal short term buffer state detected
[h264 @ 009A53F0]illegal short term buffer state detected

MPlayer interrupted by signal 11 in module: decode_video

  • MPlayer crashed by bad usage of CPU/FPU/RAM. Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and disassembly. Details in

DOCS/HTML/en/bugreports_what.html#bugreports_crash.

  • MPlayer crashed. This shouldn't happen. It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc version. If you think it's MPlayer's fault, please read DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and won't help unless you provide this information when reporting a possible bug.

Uninit audio filters...
[libaf] Removing filter dummy
uninit audio: faad
FAAD: Closing decoder!
uninit video: ffmpeg
WINSOCK2 uninit
waveOut device closed
buffer memory freed

Change History (4)

comment:1 Changed 14 years ago by dominik@…

* Bug 160 has been marked as a duplicate of this bug. *

comment:2 Changed 14 years ago by r_togni@…

Should not crash anymore with that two samples, please test (CVS mplayer & lavc)
There are still visualization problems (some frames are in wrong order), because
the ffmpeg h264 decoder is still not perfect

comment:3 Changed 14 years ago by diego@…

  • Cc diego@… added
  • op_sys changed from MinGW to All
  • Resolution set to fixed
  • Status changed from new to closed

It does not crash for me anymore. B-frame display order is also fixed, except
for one small part at the beginning, but this belongs in a different bug.

comment:4 Changed 14 years ago by diego@…

The stutter at the beginning is also fixed now.

Note: See TracTickets for help on using tickets.