Opened 9 years ago

Last modified 8 years ago

#1609 new defect

TS file format input from DVB receiver gives extremely slow video but DVDs OK

Reported by: daved@… Owned by: reimar
Priority: normal Component: vo
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

running "mplayer /dev/dvb/adaptor0/dvr0" after starting "tzap -r channel_name"
results in video output of only 2-3 frames per second, while audio OK. After
30 seconds or so, video becomes normal, but lagging many seconds behind audio
which then has periodic interruptions.

Reproducible on two machines:

  • Intel(R) Core(TM)2 Quad CPU Q9400 @ 2.66GHz; openSuSE 11.1
  • Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz; openSuSE 11.2

with two different USB DBV receivers.

Mplayer will play DVDs and mpeg files perfectly on both machines.

Running "tzap -o video_file" and subsequently "mplayer video_file" gives perfect
output.

On the second machine, running ubuntu 9.10 from a CD (not installed to disk)
and running the same tzap and mplayer binaries and most libraries (from the
openSuSE filesystem) gave perfect results. The X servers are different:

openSuSE X.Org X Server 1.6.5
ubuntu X.Org X Server 1.6.4

/proc/mtrr same on both systems:
reg00: base=0x000000000 ( 0MB), size= 1024MB, count=1: write-back
reg01: base=0x03f700000 ( 1015MB), size= 1MB, count=1: uncachable
reg02: base=0x03f800000 ( 1016MB), size= 8MB, count=1: uncachable
reg03: base=0x0e0000000 ( 3584MB), size= 256MB, count=1: write-combining

The graphics card on this machine:
(--) PCI:*(0:0:2:0) 8086:2a02:17aa:20b5 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller rev 12, Mem @ 0xf8100000/1048576, 0xe0000000/268435456, I/O @ 0x00001800/8

On the first machine listed above:
(--) PCI:*(0@1:0:0) unknown vendor (0x10de) unknown chipset (0x0421) rev 161, Me
m @ 0xe6000000/16777216, 0xd0000000/268435456, 0xe4000000/33554432, I/O @ 0x0000
9000/128, BIOS @ 0x????????/131072

Here is the output from mplayer -v
MPlayer SVN-r29975-4.3 (C) 2000-2009 MPlayer Team
CPU vendor name: GenuineIntel? max cpuid level: 13
CPU: Intel(R) Core(TM)2 Quad CPU Q9400 @ 2.66GHz (Family: 6, Model: 23, Step
ping: 10)
extended cpuid-level: 8
extended cache-info: 201351232
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNowExt: 0 SSE: 1 SSE2: 1 SSSE3: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2 SSSE3 CMOV
get_path('codecs.conf') -> '/home/daved/.mplayer/codecs.conf'
Reading /home/daved/.mplayer/codecs.conf: Can't open '/home/daved/.mplayer/codec
s.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: Can't open '/usr/local/etc/mplayer/c
odecs.conf': No such file or directory
Using built-in default codecs.conf.
Configuration:
CommandLine?: '-v' '/dev/dvb/adapter0/dvr0'
init_freetype
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
get_path('fonts') -> '/home/daved/.mplayer/fonts'
Using nanosleep() timing
get_path('input.conf') -> '/home/daved/.mplayer/input.conf'
Can't open input config file /home/daved/.mplayer/input.conf: No such file or di
rectory
Can't open input config file /usr/local/etc/mplayer/input.conf: No such file or
directory
Falling back on default (hardcoded) input config
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.
get_path('dvr0.conf') -> '/home/daved/.mplayer/dvr0.conf'

Playing /dev/dvb/adapter0/dvr0.
get_path('sub/') -> '/home/daved/.mplayer/sub/'
[file] File size is 0 bytes
STREAM: [file] /dev/dvb/adapter0/dvr0
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
LAVF_check: MPEG-2 transport stream format
Checking for YUV4MPEG2
ASF_check: not ASF guid!
Checking for REAL
Checking for SMJPEG
Searching demuxer type for filename /dev/dvb/adapter0/dvr0 ext: (null)
Checking for Nullsoft Streaming Video
Checking for MOV
Checking for VIVO
header block 1 size: 124
Checking for PVA
Checking for MPEG-TS...
TRIED UP TO POSITION 40, FOUND 47, packet_size= 188, SEEMS A TS? 1
GOOD CC: 32, BAD CC: 0
TS file format detected.
DEMUX OPEN, AUDIO_ID: -1, VIDEO_ID: -1, SUBTITLE_ID: -1,
Checking for MPEG-TS...
TRIED UP TO POSITION 120, FOUND 47, packet_size= 188, SEEMS A TS? 1
GOOD CC: 32, BAD CC: 0
PROBING UP TO 0, PROG: 0
VIDEO MPEG2(pid=512) AUDIO MPA(pid=650) NO SUBS (yet)! PROGRAM N. 0
==> Found video stream: 0

ADDED VIDEO PID 512, type: 10000002 stream n. 0
==> Found audio stream: 0

ADDED AUDIO PID 650, type: 50 stream n. 0
Opened TS demuxer, audio: 50(pid 0), video: 10000002(pid 0)...POS=43628, PROBE=0
demux_ts, switched to audio pid 650, id: 0, sh: 0x1496040
Searching for sequence header... OK!
VIDEO: MPEG2 720x576 (aspect 3) 25.000 fps 15000.0 kbps (1875.0 kbyte/s)
[V] filefmt:29 fourcc:0x10000002 size:720x576 fps:25.000 ftime:=0.0400
get_path('sub/') -> '/home/daved/.mplayer/sub/'
X11 opening display: :0.0
vo: X11 color mask: FFFFFF (R:FF0000 G:FF00 B:FF)
vo: X11 running at 1400x1050 with depth 24 and 32 bpp (":0.0" => local display)
[x11] Unknown wm type...
[x11] Current fstype setting doesn't honour any X atoms
[VO_XV] It seems there is no Xvideo support for your video card available.
[VO_XV] Run 'xvinfo' to verify its Xv support and read
[VO_XV] DOCS/HTML/en/video.html#xv!
[VO_XV] See 'mplayer -vo help' for other (non-xv) video out drivers.
[VO_XV] Try -vo x11.
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 576 (preferred colorspace: Mpeg PES)
Trying filter chain: vo
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
SwScale? params: -1 x -1 (-1=no scaling)
Trying filter chain: scale vo
The selected video_out device is incompatible with this codec.
Try appending the scale filter to your filter list,
e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Unsupported PixelFormat? -1
INFO: libavcodec init OK!
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
==========================================================================
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
dec_audio: Allocating 4608 + 65536 = 70144 bytes for output buffer.
mp3lib: using SSE optimized decore!
MP3lib: init layer2&3 finished, tables done
MMPEG 1.0, Layer II, 48000 Hz 256 kbit Stereo, BPF: 768
Channels: 2, copyright: No, original: No, CRC: Yes, emphasis: 0
AUDIO: 48000 Hz, 2 ch, s16le, 256.0 kbit/16.67% (ratio: 32000->192000)
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Building audio filter chain for 48000Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 48000Hz/2ch/s16le
Trying every known audio driver...
ao2: 48000 Hz 2 chans s16le
audio_setup: using '/dev/dsp' dsp device
audio_setup: using '/dev/mixer' mixer device
audio_setup: using 'pcm' mixer device
audio_setup: sample format: s16le (requested: s16le)
audio_setup: using 2 channels (requested: 2)
audio_setup: using 48000 Hz samplerate (requested: 48000)
audio_setup: frags: 32/32 (16384 bytes/frag) free: 524288
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
AO: Description: OSS/ioctl audio output
AO: Author: A'rpi
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
Starting playback...
Increasing filtered audio buffer size from 0 to 65536
[ffmpeg] aspect_ratio: 1.777778
VDec: vo config request - 720 x 576 (preferred colorspace: Planar YV12)
Trying filter chain: vo
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO Config (720x576->1024x576,flags=0,'MPlayer',0x32315659)
VO: [x11] 720x576 => 1024x576 Planar YV12
VO: Description: X11 ( XImage/Shm )
VO: Author: Aaron Holtzman <aholtzma@…>
Sharing memory.
[swscaler @ 0xd59360]using unscaled yuv420p -> bgra special converter
* [vo] Allocating (slices) mp_image_t, 720x576x12bpp YUV planar, 622080 bytes
A: 699.3 V: 0.0 A-V:699.285 ct: 0.000 1/ 1 ??% ??% ??,?% 0 0 ESC[J
MA: 699
.3 V: 0.1 A-V:699.254 ct: 0.004 2/ 2 ??% ??% ??,?% 1 0 ESC[JMA: 699.3 V:

0.1 A-V:699.209 ct: 0.008 3/ 3 ??% ??% ??,?% 2 0 ESC[JM* [vo] Allocatin

g (slices) mp_image_t, 720x576x12bpp YUV planar, 622080 bytes
Unicode font: 1185 glyphs.
Unicode font: 1185 glyphs.
A: 699.4 V: 699.4 A-V: -0.002 ct: 0.004 4/ 4 ??% ??% ??,?% 3 0 ESC[JM* [v
o] Allocating (slices) mp_image_t, 720x576x12bpp YUV planar, 622080 bytes
A: 699.7 V: 699.4 A-V: 0.252 ct: 0.000 5/ 5 ??% ??% ??,?% 4 0 ESC[J
MA: 700
.0 V: 699.5 A-V: 0.573 ct: -0.004 6/ 6 ??% ??% ??,?% 5 0 ESC[JMA:
etc. Then


Your system is too SLOW to play this!

(surprising given a DVD can be played)

and later
Too many video packets in the buffer: (104 in 33685480 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
ds_fill_buffer: EOF reached (stream: audio)

Broken frame at 0x1BAF20


Another interesting observation: kaffeine can read from the DVD adaptor directly and give perfect audio and video on both machines. But I much prefer mplayer, at least I did until this problem arose when I upgraded my machines.

Change History (1)

comment:1 Changed 8 years ago by compn

  • Owner changed from beastd to reimar
Note: See TracTickets for help on using tickets.