Opened 15 years ago

Closed 14 years ago

Last modified 13 years ago

#162 closed defect (wontfix)

tcss codec works for mplayer but not gmplayer

Reported by: liontooth@… Owned by: alex@…
Priority: normal Component: vo
Version: 1.0pre5 Severity: normal
Keywords: Cc: reimar, darwin_te@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Playing files made with TechSmith? Camtasia Screen Codec works great in mplayer
(congrats!), both video and sound are perfect.

When I use gmplayer, the video is a mirror image upside down and the sound
doesn't work. Details below.

Cheers,
Dave

First, mplayer (everything works):

# mplayer -vo xv Capture-003.avi
MPlayer 1.0pre5-3.3.5 (C) 2000-2004 MPlayer Team

CPU: Intel Pentium 4/Xeon/Celeron Foster 1200 MHz (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
MMX2 supported but disabled
SSE supported but disabled
SSE2 supported but disabled
CPUflags: MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX

Reading config file /etc/mplayer/mplayer.conf
Reading config file /root/.mplayer/config
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No
such file or directory
Reading /etc/mplayer/codecs.conf: 73 audio & 180 video codecs
font: can't open file: /root/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
Using Linux hardware RTC timing (1024Hz).
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 53 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such device
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.

Playing Capture-003.avi.
Cache fill: 15.82% (1327104 bytes) AVI file format detected.
VIDEO: [tscc] 1024x768 24bpp 13.000 fps 3834.7 kbps (468.1 kbyte/s)
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 22050 Hz, 1 ch, 16 bit (0x10), ratio: 44100->44100 (352.8 kbit)
Selected audio codec: [pcm] afm:pcm (Uncompressed PCM)
==========================================================================
vo: X11 running at 1600x1200 with depth 24 and 32 bpp (":0" => local display)
Disabling DPMS
==========================================================================
Opening video decoder: [vfw] Win32/VfW video codecs
Loading codec DLL: 'tsccvid.dll'
Loaded DLL driver tsccvid.dll at 7f840000
VDec: vo config request - 1024 x 768 (preferred csp: Packed YUY2)
[PP] Using codec's postprocessing, max q = 9.
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using BGR 24-bit as output csp (no 0)
Opening video filter: [flip]
Movie-Aspect is undefined - no prescaling applied.
SwScaler?: using unscaled BGR 24-bit -> Planar YV12 special converter
VO: [xv] 1024x768 => 1024x768 Planar YV12
Selected video codec: [camtasia] vfm:vfw (TechSmith? Camtasia Screen Codec)
==========================================================================
Checking audio filter chain for 22050Hz/1ch/16bit -> 22050Hz/2ch/16bit...
AF_pre: af format: 2 bps, 1 ch, 22050 hz, little endian signed int
AF_pre: 22050Hz 1ch Signed 16-bit (Little-Endian)
alsa-init: got device=0, subdevice=0
alsa-init: 1 soundcard found, using: default
alsa: 22050 Hz/2 channels/4 bpf/65536 bytes buffer/Signed 16 bit Little Endian
AO: [alsa] 22050Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 22050Hz/1ch/16bit -> 22050Hz/2ch/16bit...
Starting playback...

Next, gmplayer (picture mirror image upside down and sound fails):

# gmplayer -vo xv Capture-003.avi
MPlayer 1.0pre5-3.3.5 (C) 2000-2004 MPlayer Team

CPU: Intel Pentium 4/Xeon/Celeron Foster 1200 MHz (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
MMX2 supported but disabled
SSE supported but disabled
SSE2 supported but disabled
CPUflags: MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX

Reading config file /etc/mplayer/mplayer.conf
Reading config file /root/.mplayer/config
[cfg] read config file: /root/.mplayer/gui.conf
Reading config file /root/.mplayer/gui.conf
vo: X11 running at 1600x1200 with depth 24 and 32 bpp (":0" => local display)
Reading /root/.mplayer/codecs.conf: Can't open '/root/.mplayer/codecs.conf': No
such file or directory
Reading /etc/mplayer/codecs.conf: 73 audio & 180 video codecs
/usr/X11R6/lib/X11/fonts/TrueType/Arial.ttf doesn't look like a font
description, ignoring
Cannot load font: /usr/X11R6/lib/X11/fonts/TrueType/Arial.ttf
Failed to open /dev/rtc: Device or resource busy (it should be readable by the
user.)
Using usleep() timing
Can't open input config file /root/.mplayer/input.conf: No such file or directory
Input config file /etc/mplayer/input.conf parsed: 53 binds
Opening joystick device /dev/input/js0
Can't open joystick device /dev/input/js0 : No such device
Can't init input joystick
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support.
You will not be able to use your remote control.
[ws] screens 2 Max 1600, 1200 Org 0,0
SKIN dir 1: '/root/.mplayer/Skin'
SKIN dir 2: '/usr/share/mplayer/Skin'

Playing /mnt/storage/captures/tso/Capture-003.avi.
AVI file format detected.
VIDEO: [tscc] 1024x768 24bpp 13.000 fps 3834.7 kbps (468.1 kbyte/s)
==========================================================================
Trying to force audio codec driver family libmad...
Opening audio decoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 22050 Hz, 1 ch, 16 bit (0x10), ratio: 44100->44100 (352.8 kbit)
Selected audio codec: [pcm] afm:pcm (Uncompressed PCM)
==========================================================================
==========================================================================
Opening video decoder: [vfw] Win32/VfW video codecs
Loading codec DLL: 'tsccvid.dll'
Loaded DLL driver tsccvid.dll at 7f840000
VDec: vo config request - 1024 x 768 (preferred csp: Packed YUY2)
[PP] Using codec's postprocessing, max q = 9.
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
VDec: using BGR 24-bit as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
SwScaler?: using unscaled BGR 24-bit -> Planar YV12 special converter
VO: [xv] 1024x768 => 1024x768 Planar YV12
Selected video codec: [camtasia] vfm:vfw (TechSmith? Camtasia Screen Codec)
==========================================================================
Checking audio filter chain for 22050Hz/1ch/16bit -> 22050Hz/2ch/16bit...
AF_pre: af format: 2 bps, 1 ch, 22050 hz, little endian signed int
AF_pre: 22050Hz 1ch Signed 16-bit (Little-Endian)
Could not open/initialize audio device -> no sound.
Audio: no sound
Starting playback...
V: 30.1 392 2% 30% 0.0% 0 0 49%
Exiting... (Quit)

Change History (5)

comment:1 Changed 15 years ago by reimar

Concerning the sound: maybe you set a different audio output device in MPlayer?
I think there was a bug in one of the aos (SDL?) that could cause something like
this - trying CVS might help as well.
Concerning the video - well, the Gui is a very ugly piece of code. Could you
open your gui.conf and make sure that you have
v_flip = "-1"
and not
v_flip = "0" ?
Unfortunately this change might cause gmplayer to crash when you have
postprocessing enabled... So another reason to use CVS.

comment:2 Changed 15 years ago by dominik@…

  • Cc Reimar.Doeffinger@… added

Reimar: is this fixed now or what? If it is, please close the bug.

comment:3 Changed 15 years ago by reimar

The crash yes, but the gui still doesn't automatically flip for videos that need
it I think.

comment:4 Changed 14 years ago by r_togni@…

  • Resolution set to wontfix
  • Status changed from new to closed

We have a native tscc decoder now, so this issue with binary codec (that works
in plain mplayer btw) is obsolete.

comment:5 Changed 13 years ago by reimar

  • Cc darwin_te@… added

* Bug 530 has been marked as a duplicate of this bug. *

Note: See TracTickets for help on using tickets.