Opened 9 years ago

Last modified 8 years ago

#1620 closed defect (fixed)

[PATCH] stop-xscreensaver is disabled by default

Reported by: l.lunak@… Owned by: reimar
Priority: normal Component: vo
Version: 1.0rc2 Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The option -stop-xscreensaver is disabled by default, resulting in KDE screensaver activating while playing videos in MPlayer. As the option does the sensible thing and there is no normal reason to have it disabled, it doesn't make sense to have it disabled by default. Especially since the documentation states that it is the right thing to do.

See attached patch for a suggested fix.

Note that the -stop-xscreensaver option is also affected by https://bugs.freedesktop.org/show_bug.cgi?id=25855 , making it non-functional with latest X.Org.

Attachments (1)

mplayer.patch (386 bytes) - added by l.lunak@… 9 years ago.
mplayer patch

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by l.lunak@…

mplayer patch

comment:1 Changed 9 years ago by l.lunak@…

comment:2 Changed 8 years ago by compn

  • Owner changed from beastd to reimar

comment:3 Changed 8 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed, patriotact@gmail.com
  • Summary changed from stop-xscreensaver is disabled by default to [PATCH] stop-xscreensaver is disabled by default

note that since none of the screensaver or power management guys could agree on a single api, mplayer now uses the -heartbeat-cmd to allow you to exec whatever program to disable screensaver.

Note: See TracTickets for help on using tickets.