Opened 9 years ago

Closed 9 years ago

#1626 closed defect (fixed)

can't compile mplayer when configured with --disable-mencoder

Reported by: peter.ginchev@… Owned by: diego@…
Priority: normal Component: build system
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When compiling with --disable-mencoder, the linking of mplayer finishes unsuccessfully, because the linker cannot find h263_encode_init(), when used by libavcodec/snow.c:2980.
It is defined in libavcodec/ituh263enc.c:772 but in libavcodec/Makefile it is included when CONFIG_H263_ENCODER flag is enabled.

I don't know what's the exact logic of enabling CONFIG_H263_ENCODER, but it is disabled when '--disable-mencoder'

For completeness I checked that mplayer is compiled successfully without disabling mencoder.

Change History (1)

comment:1 Changed 9 years ago by diego@…

  • op_sys changed from Other to All
  • rep_platform changed from PC (x86) to All
  • Resolution set to fixed
  • Status changed from new to closed

This has been fixed in FFmpeg.

Note: See TracTickets for help on using tickets.