Opened 15 years ago

Closed 13 years ago

Last modified 13 years ago

#164 closed defect (worksforme)

mencoder vf bug

Reported by: na498@… Owned by: alex@…
Priority: normal Component: vf
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I tried to encode a video file with mencoder.
I used the 081204 CVS version mencoder
(ftp://ftp1.mplayerhq.hu/MPlayer/releases/win32-beta/MPlayer-mingw32-dev-CVS-
081204.zip).

Running the following command (comp.bat) :
"c:\bin\mplayer\mencoder "Pablo Francisco - Stand Up.mpg" -oac copy -ovc lavc -
lavcopts vcodec=mpeg4:vbitrate=900 -vf scale=480:360" gives the following
error at 97%:


D:\video>c:\bin\mplayer\mencoder "Pablo Francisco - Stand Up
.mpg" -oac copy -ovc lavc -lavcopts vcodec=mpeg4:vbitrate=900 -vf scale=480:360

MEncoder dev-CVS-041208-09:59-3.2.3 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP/XP-M Barton (Family: 6, Stepping: 0)
Detected cache-line size is 64 bytes
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled with runtime CPU detection - WARNING - this is not optimal!
To get best performance, recompile MPlayer with --disable-runtime-cpudetection.
File not found: 'frameno.avi'
Failed to open frameno.avi
success: format: 0 data: 0x0 - 0x18718f04
MPEG-PS file format detected.
VIDEO: MPEG2 480x576 (aspect 2) 25.000 fps 2520.0 kbps (315.0 kbyte/s)
[V] filefmt:2 fourcc:0x10000002 size:480x576 fps:25.00 ftime:=0.0400
==========================================================================
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 28000->176400 (224.0 kbit)
Selected audio codec: [mp3] afm:mp3lib (mp3lib MPEG layer-2, layer-3)
==========================================================================
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1 (-1=autodetect) osd: 1
Opening video filter: [scale w=480 h=360]
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 480 x 576 (preferred csp: Mpeg PES)
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
audiocodec: framecopy (format=50 chans=2 rate=44100 bits=16 bps=28000 sample-1)
Writing AVI header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp
h
eader.
VDec: vo config request - 480 x 576 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
SwScaler?: reducing / aligning filtersize 1 -> 4
SwScaler?: reducing / aligning filtersize 1 -> 4
SwScaler?: reducing / aligning filtersize 8 -> 7
SwScaler?: reducing / aligning filtersize 8 -> 7

SwScaler?: BICUBIC scaler, from Planar YV12 to Planar YV12 using MMX2
videocodec: libavcodec (480x360 fourcc=58564944 [DIVX])
New_Face failed. Maybe the font path is wrong. 0mb A-V:0.004 [0:0]
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
ODML: Aspect information not (yet?) available or unspecified, not writing vprp
h
eader.

1 duplicate frame(s)!
Pos: 0.8s 22f ( 0%) 0fps Trem: 2min 124mb A-V:0.084 [0:224]
Skipping frame!
Pos: 1.2s 32f ( 0%) 0fps Trem: 2min 122mb A-V:0.082 [1549:224]
Skipping frame!
Assertion failed: lastInChrBuf + 1 - chrSrcSliceY >= 0, file
swscale_template.c,

line 2683

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.


However "c:\bin\mplayer\mencoder "Pablo Francisco - Stand Up.mpg" -oac copy -
ovc lavc -lavcopts vcodec=mpeg4:vbitrate=900" (comp2.bat) encodes the file
fine.

I've uploaded the files to ftp://ftp1.mplayerhq.hu/MPlayer/incoming/pablo

Change History (4)

comment:1 Changed 13 years ago by reimar

Can someone reproduce? Does the problem persist in the latest version?

comment:2 Changed 13 years ago by reynaldo@…

(In reply to comment #1)

Can someone reproduce? Does the problem persist in the latest version?

Hardly, seems the sample is missing.

comment:3 Changed 13 years ago by reimar

Sample is now in incoming/old-incoming/pablo.

comment:4 Changed 13 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

And it works for me. Maybe it was fixed, maybe there is some other reason for
it (e.g. I did not test under windows). If someone can reproduce, reopen.

Note: See TracTickets for help on using tickets.