Opened 9 years ago

Closed 8 years ago

#1660 closed defect (worksforme)

svn rev 30827 Segmentation fault

Reported by: kuh3h3@… Owned by: reimar
Priority: important Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

media/sdc1$ gdb mplayer
GNU gdb (GDB) 7.0.50.20091013-cvs
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/mplayer...done.
(gdb) r ueto03.wmv
Starting program: /usr/bin/mplayer ueto03.wmv
[Thread debugging using libthread_db enabled]
MPlayer SVN-r30827-4.3.3 (C) 2000-2010 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing ueto03.wmv.
ASF file format detected.
[asfheader] Video stream found, -vid 1
[asfheader] Audio stream found, -aid 2
ASF: No video stream found.

Program received signal SIGSEGV, Segmentation fault.
0x081af13a in demux_open_asf (demuxer=0x8f74ef8) at libmpdemux/demux_asf.c:659
659 sh_audio=demuxer->audio->sh;sh_audio->ds=demuxer->audio;
(gdb) bt full
#0 0x081af13a in demux_open_asf (demuxer=0x8f74ef8) at libmpdemux/demux_asf.c:659

asf = 0x8f72558
sh_audio = 0x0
sh_video = <value optimised out>

#1 0x081ad732 in demux_open_stream (stream=0x8f74560, file_format=6, force=0, audio_id=1, video_id=-1, dvdsub_id=0,

filename=0x8f5a280 "ueto03.wmv") at libmpdemux/demuxer.c:974

demux2 = <value optimised out>
demuxer = 0x8f74ef8
sh_video = <value optimised out>
demuxer_desc = 0x8816fa0
fformat = 6
i = 7

#2 0x081ad95d in demux_open (vs=0x8f74560, file_format=0, audio_id=1, video_id=-1, dvdsub_id=0, filename=0x8f5a280 "ueto03.wmv")

at libmpdemux/demuxer.c:1154

as = 0x0
ss = 0x0
vd = <value optimised out>
ad = <value optimised out>
sd = <value optimised out>
res = <value optimised out>
afmt = 0
sfmt = 0
demuxer_type = 0
audio_demuxer_type = 0
sub_demuxer_type = 0
demuxer_force = 0
audio_demuxer_force = 0
sub_demuxer_force = 0

#3 0x080c1d1b in main (argc=2, argv=0xbfffe454) at mplayer.c:3304

mem_ptr = <value optimised out>
opt_exit = 0
i = <value optimised out>
gui_no_filename = 0
last_heartbeat = 0

(gdb) i r
eax 0x0 0
ecx 0x8f75b68 150428520
edx 0x8f72408 150414344
ebx 0x8f74ef8 150425336
esp 0xbfffa020 0xbfffa020
ebp 0xbfffa058 0xbfffa058
esi 0x8f72558 150414680
edi 0x8f74560 150422880
eip 0x81af13a 0x81af13a <demux_open_asf+357>
eflags 0x10202 [ IF RF ]
cs 0x73 115
ss 0x7b 123
ds 0x7b 123
es 0x7b 123
fs 0x0 0
gs 0x33 51
(gdb) disass $pc-32 $pc+32
Dump of assembler code from 0x81af11a to 0x81af15a:
0x081af11a <demux_open_asf+325>: add $0x24,%al
0x081af11c <demux_open_asf+327>: add $0xe8000000,%eax
0x081af121 <demux_open_asf+332>: and $0xf0,%cl
0x081af124 <demux_open_asf+335>: decl 0x4894443(%ebx)
0x081af12a <demux_open_asf+341>: and $0xe8,%al
0x081af12c <demux_open_asf+343>: lcall $0x74c0,$0x85ffffeb
0x081af133 <demux_open_asf+350>: dec %edi
0x081af134 <demux_open_asf+351>: mov 0x44(%ebx),%edx
0x081af137 <demux_open_asf+354>: mov 0x64(%edx),%eax
0x081af13a <demux_open_asf+357>: mov %edx,(%eax)
0x081af13c <demux_open_asf+359>: mov 0xbc(%eax),%edx
0x081af142 <demux_open_asf+365>: movzwl (%edx),%edx
0x081af145 <demux_open_asf+368>: mov %edx,0x8(%eax)
0x081af148 <demux_open_asf+371>: mov 0x1c(%ebx),%eax
0x081af14b <demux_open_asf+374>: mov 0x8(%eax),%eax
0x081af14e <demux_open_asf+377>: test %eax,%eax
0x081af150 <demux_open_asf+379>: jne 0x81aefed <demux_open_asf+24>
0x081af156 <demux_open_asf+385>: movl $0x0,0x40(%ebx)
End of assembler dump.
(gdb) q
A debugging session is active.

Inferior 1 [process 24623] will be killed.

Quit anyway? (y or n) y

$ LANG=C svn info
Path: .
URL: svn://svn.mplayerhq.hu/mplayer/trunk
Repository Root: svn://svn.mplayerhq.hu/mplayer
Repository UUID: b3059339-0415-0410-9bf9-f77b7e298cf2
Revision: 30827
Node Kind: directory
Schedule: normal
Last Changed Author: stefano
Last Changed Rev: 30827
Last Changed Date: 2010-03-04 10:02:24 +0900 (Thu, 04 Mar 2010)

Change History (3)

comment:2 Changed 8 years ago by compn

  • Owner changed from r_togni@… to reimar

comment:3 Changed 8 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

Was never reproducible for, but definitely can't happen in that form anymore in since SVN r32686 since that code no longer exists in that form.

Note: See TracTickets for help on using tickets.