Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#167 closed defect (fixed)

Default framerate for NTSC video capture is wrong with the V4L2 driver.

Reported by: eyager@… Owned by: moritz@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The default framerate for capturing NTSC video should be 29.97 fps, not 29.00.

mencoder -v -tv driver=v4l2:width=366:height=480:outfmt=yuy2:\
adevice=/dev/dsp1:audiorate=32000:amode=1:\
normid=1:chanlist=us-cable:\
brightness=-5:contrast=0:saturation=50:hue=5:channel=$1

{relevant debug information}
v4l2: set format: YUYV
v4l2: set input: 0
Selected norm id: 1
v4l2: set norm: NTSC
v4l2: set width: 366
v4l2: set height: 480
Selected channel list: us-cable (including 133 channels)
Requested channel: 26
Selected channel: 26 (freq: 235.250)
Current frequency: 3764 (235.250)
Current frequency: 3764 (235.250)
==> Found video stream: 0
v4l2: get format: YUYV
v4l2: get fps: 29.000000
v4l2: get width: 366
v4l2: get height: 480
v4l2: set audio samplerate: 32000
v4l2: get audio format: 16
==> Found audio stream: 0
v4l2: get audio samplerate: 32000
v4l2: get audio samplesize: 2
v4l2: get audio channels: 2

TV audio: 2 channels, 16 bits, 32000 Hz

Audio capture - buffer 256 blocks of 16384 bytes, skew average from 16 meas.
Using a ring buffer for maximum 374 frames, 125 MB total size.
v4l2: set Brightness: 31130 [0, 65535]
v4l2: set Hue: 34406 [0, 65535]
v4l2: set Saturation: 49151 [0, 65535]
v4l2: set Contrast: 32768 [0, 65535]
[V] filefmt:9 fourcc:0x32595559 size:366x480 fps:29.00 ftime:=0.0334

Change History (1)

comment:1 Changed 13 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

There was a typecast missing, should be fixed since SVN r16275.

Note: See TracTickets for help on using tickets.