Opened 9 years ago

Closed 9 years ago

#1686 closed defect (fixed)

video format 0x34564C46

Reported by: d.okias@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hello, I have lot videos which use this format and now it stopped work in mplayer. Kaffeine is fine, even I can recall it worked some time ago with mplayer.
it worked some time ago.

Playing video.flv.
libavformat file format detected.
[flv @ 0x1c07480]Estimating duration from bitrate, this may be inaccurate
[lavf] Video stream found, -vid 0
[lavf] Audio stream found, -aid 1
VIDEO: [FLV4] 584x438 0bpp 29.970 fps 370.8 kbps (45.3 kbyte/s)
==========================================================================
Cannot find codec matching selected -vo and video format 0x34564C46.
==========================================================================

Change History (4)

comment:1 Changed 9 years ago by compn

does this patch fix it?

Index: codecs.conf
===================================================================
--- codecs.conf (revision 31109)
+++ codecs.conf (working copy)
@@ -2132,6 +2132,7 @@

info "FFmpeg VP6 Flash"
status working
fourcc VP6F

+ fourcc FLV4

driver ffmpeg
dll "vp6f"
out YV12

comment:2 Changed 9 years ago by adiazcay@…

The same for me. Working on Mandriva cooker. Some update this month screwed this, but I've not noticed it until yesterday.

After googling a lot, I've found threads talking about a codecs.conf file that I was unable to find in my system, until I've read that now it's internally implemented.

But I've taken a copy of the file from your git, saved to my ~/.mplayer directory and applied your suggested change. After this, I can watch my stored flv videos again.

Regards

comment:3 Changed 9 years ago by d.okias@…

YES, patch fixed it :-) Thank you.

comment:4 Changed 9 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed in svn.

Note: See TracTickets for help on using tickets.