Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1704 closed defect (fixed)

"read error:: Interrupted system call" playing mms://*.wma stream

Reported by: mike.parker@… Owned by: r_togni@…
Priority: normal Component: streaming
Version: HEAD Severity: major
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Invoking mplayer version SVN-r31206-snapshot-4.4.3 with the following command line:

mplayer -vc null -vo null -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao alsa mms://wm-acl.bbc.co.uk/wms/radio2coyopa/radio_2_-_wednesday_1705.wma

Results in the following fatal error:

<snip>
read error:: Interrupted system call
pre-header read failed
<snip>

The same command line invocation of mplayer with the earlier SVN-r30986-snapshot-4.4.3 version works without issue.

Change History (4)

comment:1 Changed 9 years ago by mike.parker@…

Additional information:

Platform in Fedora 12 x86_64, kernel 2.6.32.12-115

comment:2 Changed 9 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

I think this regression was fixed in less than a day after it was introduced, so it should be fixed since some time.
Reopen if not

comment:3 Changed 9 years ago by mike.parker@…

It is present in the ATRPMS package dated 2010-05-24.

Can you give a date for when it was introduced?

comment:4 Changed 9 years ago by reimar

This or related issues existed from 2010-05-23 to 2010-05-28 inclusive.

Note: See TracTickets for help on using tickets.