Opened 10 years ago

Last modified 9 years ago

#1715 closed defect (fixed)

rtsp streaming doesn't work with latest liveMedia release

Reported by: dcoppa@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

in latest live release (live.2010.06.11), the function RTSPClient::playMediaSession has changed. Because of this, the check "if (!rtspClient->playMediaSession(*mediaSession)) break;" in libmpdemux/demux_rtp.cpp always fails.
Changing it to "if (rtspClient->playMediaSession(*mediaSession) != 0) break;" solves the problem.

Change History (4)

comment:1 Changed 10 years ago by dcoppa@…

  • rep_platform changed from Other to All

comment:2 Changed 9 years ago by kyl416@…

I think it's a bug in liveMedia itself since starting with the 2010.05.29 release, streams that require rtsp over tcp haven't worked in mplayer, vlc or even their own openRTSP test program.

comment:3 Changed 9 years ago by kyl416@…

liveMedia located the bug and as of a few revisions ago it should be working again.

comment:4 Changed 9 years ago by compn

  • Resolution set to fixed
  • Status changed from new to closed, patriotact@gmail.com

btw try your streams with mplayer ffmpeg://rtsp... now, as ffmpeg supports more streams than live555.

Note: See TracTickets for help on using tickets.