Opened 9 years ago

Last modified 9 years ago

#1737 new defect

mencoder -oac faac cannot make AAC-LC, only MAIN

Reported by: julianhughes@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

MEncoder SVN-r31758-snapshot-4.4.4
(FFmpeg version SVN-r23386)

From man mencoder:

object=<1-4>

object type complexity

1 MAIN (default)
2 LOW
3 SSR
4 LTP (extremely slow)

So if I use

"-oac faac -faacopts br=#:mpeg=4:object=2" as part of my mencoder options it should give me AAC-LC at # bitrate but it only produces MAIN profile. I have also tried object=1 and object=3, and tried with no bitrate specified, and have tried mpeg=2. Only object=1 or object=2 work but are unfortunately producing identical result - MAIN profile AAC, unsupported for typical handheld devices such as phones, tablets etc.

I find that if I instead use -oac copy and then on the result run ffmpeg -i some_movie.avi -vcodec copy -ac 2 -acodec libfaac -ab 128kb some_movie.mp4 I do indeed get the movie with AAC-LC which will play on my device, so it seems to me that the mencoder faacopts are somewhat broken. Am I missing something?

Change History (1)

comment:1 Changed 9 years ago by julianhughes@…

OK I found what I'm missing...

The docs are wrong, or at least don't match the reality. Whether this is a bug in the encoder or in the docs I don't know, but one or the other should be changed. To produce AAC-LC one must specify mpeg=4:object=2:raw, but the docs and examples such as those at http://www.mplayerhq.hu/DOCS/HTML/en/ omit the 'raw' option, and instead offer examples using only "-faacopts br=192:mpeg=4:object=2"

Note: See TracTickets for help on using tickets.