Opened 9 years ago

Closed 9 years ago

#1746 closed defect (fixed)

switch_audio with mpegpes output doesn't work

Reported by: mopfattn@… Owned by: reimar
Priority: normal Component: ao
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When using the switch_audio command in slave mode with the mpegpes output MPlayer reports this error:

...
switch_audio
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[ac3 @ 0x8988f40]frame sync error
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
==========================================================================
Opening /dev/dvb/adapter0/audio0
DVB AUDIO DEVICE: Device or resource busy
Failed to initialize audio driver 'mpegpes'
Could not open/initialize audio device -> no sound.

MPlayer is started with the following command:

mplayer -vo mpegpes -ao mpegpes -framedrop -cache-min 10 -slave -nolirc -quiet -osdlevel 0 -aid 128 dvdrip.vob

It looks like MPlayer can find the new audio ID and tries to initialize the audio device again without closing the old one.

Please see the attachment for a debug log.

Attachments (1)

output.txt (1.3 KB) - added by mopfattn@… 9 years ago.
debug log

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by mopfattn@…

debug log

comment:1 Changed 9 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed by SVN r31871.

Note: See TracTickets for help on using tickets.