Opened 10 years ago

Closed 10 years ago

#1752 closed defect (fixed)

mkv lavf demuxer, subtitles are sticky

Reported by: pigipau@… Owned by: reimar
Priority: normal Component: demuxer
Version: 1.0rc4 Severity: normal
Keywords: Cc: john@…, overture2112@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Subtitles are sticky in mplayer when playing mkv files with subtitles; every subtitle line is displayed until the begin time for the next one, regardless of its own end time.

As a consequence, starting from the begin time for the first subtitle line, a subtitle line will always be visible (the last displayed subtitle never disappears) except by user intervention (e.g. toggling visibility of subtitles).

The problem disappears if I add:

[extension.mkv]
demuxer=mkv

to my config file, therefore I suppose the lavf demuxer is to blame.

I am running mplayer from debian-multimedia.org on debian testing/unstable amd64. I'm not sure which version was the first to suffer from this problem (I must assume it's been there since the switch to lavf demuxer), but it seems that versions currently on repository for debian testing and unstable (2:1.0~rc3+svn20100603-0.0 and 2:1.0~rc3++svn20100804-0.0 respectively) are both affected.

Please feel free to ask for more details if needed.

Change History (3)

comment:1 Changed 10 years ago by john@…

  • Cc john@… added
  • Version changed from unspecified to 1.0rc4

I notice a similar issue when seeking mkv files. If I rewind (seek backwards) I'll see the same subtitle played for the number of times I've seeked over the position.

i.e.
I am playing a file and the subtitle starts at (minute:second) 0:15 and ends at 0:22.
I watch the file through to 0:23 and rewind back to 0:14.
When 0:15 hits, I see the subtitle displayed twice.
If I then rewind back to 0:14 again, when 0:15 hits I see the subtitle displayed 3 times.
All future (not yet viewed) subtitles display fine.

I'm using mplayer on linux version 1.0_rc4 2010-06-12 (gentoo build)

comment:2 Changed 10 years ago by overture2112@…

  • Cc overture2112@… added

I also get this issue with svn r32025.

comment:3 Changed 10 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in SVN r32032.

Note: See TracTickets for help on using tickets.