Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1762 closed defect (invalid)

-lvorbisenc missing in LDFLAGS

Reported by: wbrana@… Owned by: diego@…
Priority: normal Component: build system
Version: HEAD Severity: major
Keywords: Cc: spam3910807@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

ibavcodec/libavcodec.a(libvorbis.o): In function `oggvorbis_encode_init':
libvorbis.c:(.text.unlikely+0x9d): undefined reference to `vorbis_encode_setup_vbr'
libvorbis.c:(.text.unlikely+0xd7): undefined reference to `vorbis_encode_setup_managed'
libvorbis.c:(.text.unlikely+0xf6): undefined reference to `vorbis_encode_ctl'
libvorbis.c:(.text.unlikely+0x12e): undefined reference to `vorbis_encode_ctl'
libvorbis.c:(.text.unlikely+0x13a): undefined reference to `vorbis_encode_setup_init'
collect2: ld returned 1 exit status
make: * [mencoder] Error 1
make:
* Waiting for unfinished jobs....
libavcodec/libavcodec.a(libvorbis.o): In function `oggvorbis_encode_init':
libvorbis.c:(.text.unlikely+0x9d): undefined reference to `vorbis_encode_setup_vbr'
libvorbis.c:(.text.unlikely+0xd7): undefined reference to `vorbis_encode_setup_managed'
libvorbis.c:(.text.unlikely+0xf6): undefined reference to `vorbis_encode_ctl'
libvorbis.c:(.text.unlikely+0x12e): undefined reference to `vorbis_encode_ctl'
libvorbis.c:(.text.unlikely+0x13a): undefined reference to `vorbis_encode_setup_init'
collect2: ld returned 1 exit status
make: * [mplayer] Error 1

Change History (2)

comment:1 Changed 9 years ago by diego@…

  • op_sys changed from Linux to All
  • rep_platform changed from PC (x86_64) to All
  • Resolution set to invalid
  • Severity changed from blocker to major
  • Status changed from new to closed

This is missing too much information to even begin being useful. Reproducing the problem is impossible --> INVALID.

comment:2 Changed 9 years ago by spam3910807@…

  • Cc spam3910807@… added

Hi!

I can provide additional information. Building mplayer-1.0rc4 fails in gentoo linux. To reproduce, try to build mplayer with external libvorbis (1.3.2) and mencoder enabled:

$ tar xjf MPlayer-1.0rc4.tar.bz2
$ cd MPlayer-1.0rc4
$ ./configure --prefix=/tmp/mplayer-build --disable-tremor-internal
$ make

libavcodec/libavcodec.a(libvorbis.o): In function `oggvorbis_encode_init':
libvorbis.c:(.text.unlikely+0xa9): undefined reference to `vorbis_encode_setup_vbr'
libvorbis.c:(.text.unlikely+0xc8): undefined reference to `vorbis_encode_setup_managed'
libvorbis.c:(.text.unlikely+0x100): undefined reference to `vorbis_encode_ctl'
libvorbis.c:(.text.unlikely+0x10c): undefined reference to `vorbis_encode_setup_init'
collect2: ld returned 1 exit status

Workaround is adding --extra-libs-mencoder=-lvorbisenc to configure or ldflags.

Bug is also discussed in gentoo bugzilla:
https://bugs.gentoo.org/show_bug.cgi?id=344593

Note: See TracTickets for help on using tickets.