Opened 9 years ago

Closed 9 years ago

#1782 closed defect (fixed)

Cache doesn't work properly

Reported by: pantranzystor@… Owned by: reimar
Priority: normal Component: core
Version: unspecified Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hi,
Here's the scenario: arch linux torrent box with shares exported using Samba. Windows XP PC on which i watch the movies from torrent box. PCs connected using LAN ethernet 100Mbps.

Share mounted using windows mount tool, everything works fine, no special lag in exploring directories, arrount 9-10MB/s when copying something.

I try to watch movies without downloading it to home PC, on standard definition movies or highly compressed 720p videos run smooth. But with high bitrate 720p (arround 3000-4000Kbps) comes problems. I have of course set the -cache parameter

On highly dynamic scenes the video freezes along with subtitles, but sound goes on without scratching. First I've thought that my hardware is too old to play such files, but after copying movie onto hard drive it ran without any problems. MPlayer doesn't show any disturbing messages in log. I' tried many builds.

Like i said before, -cache parameter is set, and I' tried even high number, like 40000.

Sorry for my English and thanks in advance for reply!

Daniel.

Change History (2)

comment:1 Changed 9 years ago by compn

  • Cc patriotact@… added

does cpu hit 100% when playing hd action scene over the network?
if so, it maybe a bad network card. i had that problem with realtec card before.

also try -cache 8192 -cache-min 90

comment:2 Changed 9 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed since about SVN r32616.
Note that I consider the issue a linux kernel bug: It does not do sufficient read-ahead for remote filesystems, causing very bad bandwidth usage if the application does small reads (previously MPlayer read only 2 kB at a time, this was now changed to 64 kB, which is also the maximum that standard SAMBA protocol supports per transfer).

Note: See TracTickets for help on using tickets.