Opened 9 years ago

Last modified 9 years ago

#1789 closed defect (duplicate)

-alang disables -sb

Reported by: mennucc1@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

hi,

it seems that, when the option '-alang' is present, then mplayer and mencoder ignores the option '-sb'

The bug is present in SVN 31044 .

I attach the typescript 'pippo8.txt' of the command

# mencoder -v -v -sb 343400000 -endpos 2 -ovc copy -oac copy -o /data9/tv/pippo8.avi /data9/tv/2010-09-09_11-40_4400_-_Stagione_3.ts

and the typescript 'pippo9.txt' of the command

# mencoder -v -v -sb 343400000 -endpos 2 -ovc copy -oac copy -o /data9/tv/pippo9.avi -alang it /data9/tv/2010-09-09_11-40_4400_-_Stagione_3.ts

The input file is a MPEG-TS file from DVB-T obtained using 'dvbstreamer'.

If you diff the two attachments, you will see at a certain point

-Opened TS demuxer, audio: 50(pid 0), video: 10000002(pid 0)...POS=343410012, PR
-seek to 0x147804A0
-s->pos=1478A800 newpos=14780000 new_bufpos=147804A0 buflen=0
+Opened TS demuxer, audio: 50(pid 0), video: 10000002(pid 0)...POS=0, PROBE=0
+seek to 0x0
+s->pos=1478A800 newpos=0 new_bufpos=0 buflen=0

a.

Change History (1)

comment:1 Changed 9 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed, patriotact@gmail.com

dupe bug

Note: See TracTickets for help on using tickets.