Opened 15 years ago

Closed 15 years ago

Last modified 14 years ago

#179 closed defect (worksforme)

Closing MPlayer with KDE makes terminals stop working properly

Reported by: drscotsman@… Owned by: alex@…
Priority: normal Component: core
Version: 1.0pre5 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When I am playing a video (file type is irrelevent) with MPlayer, and I close it
either with Alt+F4 or by pressing the close button in the Window decorations
(both cases are using KDE for this) the terminal stops working properly. For
example (most of the numbers differ)

"VO: [xv] 400x288 => 400x288 Planar YV12
A: 2.6 V: 2.6 A-V: -0.008 ct: -0.016 66/ 66 3% 1% 0.5% 3 0 98%

MPlayer interrupted by signal 15 in module: sleep_usleep
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"

after 140 requests (138 known processed) with 0 events remaining.

sh-3.00$ sh-3.00$ sh-3.00$ sh-3.00$ sh-3.00$"

Sometimes a different error is displayed instead of the XIO: fatal IO error

"X connection to :0.0 broken (explicit kill or server shutdown)."

The line of "sh-3.00$"s is caused by me pressing return after returning to the
prompt and attempting to make a line break. Also terminal input is not
displayed i.e. pressing up to display the previous command has no effect, and
typing any new commands has no effect. However the input is still taken in i.e.
typing "ls" and pressing return still carries out the ls command, even though ls
is not displayed in the terminal.

The terminal messes up using both sh and bash, and using both KDE's Konsole and
Xterm. Unfortunatly I don't have MPlayer working in a terminal with
framebuffer, so I can only test with these terminal emulators. I have only
tested this in KDE.

Here is information of my system from the ver_linux script:

"Linux ryan 2.6.10-rc3 #1 Sat Dec 18 20:30:52 GMT 2004 i686 AMD Athlon(tm) XP
2400+ AuthenticAMD GNU/Linux

Gnu C 3.4.1
Gnu make 3.80
binutils 2.15.92.0.2
util-linux 2.12
mount 2.12
module-init-tools 3.0
e2fsprogs 1.35
reiserfsprogs line
reiser4progs line
Linux C Library 2.3.4
Dynamic linker (ldd) 2.3.4
Procps 3.1.15
Net-tools 1.60
Kbd 1.12
Sh-utils 5.2.1
Modules Loaded evdev snd_intel8x0 snd_ac97_codec snd_pcm_oss snd_pcm
snd_timer snd_page_alloc snd_mixer_oss snd soundcore usbcore nvidia"

And here is MPlayer's output on how it was compiled:

"MPlayer 1.0pre5-3.4.1 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred 2001 MHz (Family: 6,
Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE"

I have not experienced this problem with any other Linux kernel. I have used
2.6.9 and 2.6.10-rc1 without problems.

Change History (2)

comment:1 Changed 15 years ago by reimar

  • Resolution set to worksforme
  • Status changed from new to closed

Even if this is fixed you should quit MPlayer by pressing q, not by sending it
SIGTERM (which is what KDE does, which I btw. find extremely stupid. Fluxbox
just doesn't show a close button for applications that don't support it).
Processing this correctly is probably more work than it's worth.
Also, please provide a full mplayer -v log, as e.g. "killall mplayer" doesn't
break my terminal (maybe try pre6).
Both using gmplayer or using -vo sdl will fix it as well, because they support
the close button.

comment:2 Changed 14 years ago by reimar

MPlayer now catches SIGPIPE, it seems to me this should fix it. Please try with
very latest CVS and report back.

Note: See TracTickets for help on using tickets.