Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#181 closed defect (invalid)

MPlayer "wraps" HDTV-WMV-Videos horizontally

Reported by: pub_br_mplayerhq.hu@… Owned by: alex@…
Priority: normal Component: vo
Version: 1.0pre6 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

My gfx configuration: Matrox G450 DH AGP w/ 32 MB @ 1280x960,
XFree86 4.1.0.

Get the following file:


<http://download.microsoft.com/download/4/1/b/41b10a4f-f4f4-4692-aa44-a458d0047e91/Robotica_720.exe>

unzip it (unzip Robotica_720.exe) and play it using

mplayer -nosound -vo xmga Robotica_720.wmv (with no ~/.mplayer)

(-nosound, because my 1-GHz machine is too slow)

The video gets wrapped strangely, so that the right fourth of
the picture shows the left fourth, and vice versa. The middle
half (two fourths) is correct.

When I move the video window to the right, something
interesting happens: As soon as the window has moved quite
exactly 20 pixels from the left border, the left fourth (still
showing the right fourth of the video) gets narrower, while at
the same time, the middle half of the video extends to the left
(by the same amount that the left fourth decreases), the new
parts of it showing the correct left fourth.

Nearly the same can be seen when moving the video window to the
left, just without the 20-pixel offset.

This bug occurs with both xmga and mga. x11 shows it correctly
(but very slow), xv and sdl simply make MPlayer crash.

I'll attach the program outputs hereafter.

Attachments (5)

log.xmga (59.0 KB) - added by pub_br_mplayerhq.hu@… 14 years ago.
Output of "mplayer -v -v -frames 1 -vo xmga -nosound Robotica_720.wmv > log.xmga 2>&1"
log.mga (58.7 KB) - added by pub_br_mplayerhq.hu@… 14 years ago.
Output of "mplayer -v -v -frames 1 -vo mga -nosound Robotica_720.wmv > log.mga 2>&1"
log.xv (59.6 KB) - added by pub_br_mplayerhq.hu@… 14 years ago.
Output of "mplayer -v -v -frames 1 -vo xv -nosound Robotica_720.wmv > log.xv 2>&1"
log.sdl (35.0 KB) - added by pub_br_mplayerhq.hu@… 14 years ago.
Output of "mplayer -v -v -frames 1 -vo sdl -nosound Robotica_720.wmv > log.sdl 2>&1"
log.x11 (59.3 KB) - added by pub_br_mplayerhq.hu@… 14 years ago.
Output of "mplayer -v -v -frames 1 -vo x11 -nosound Robotica_720.wmv > log.x11 2>&1"

Download all attachments as: .zip

Change History (18)

Changed 14 years ago by pub_br_mplayerhq.hu@…

Output of "mplayer -v -v -frames 1 -vo xmga -nosound Robotica_720.wmv > log.xmga 2>&1"

comment:1 Changed 14 years ago by pub_br_mplayerhq.hu@…

xmga: picture gets wrapped as described

Changed 14 years ago by pub_br_mplayerhq.hu@…

Output of "mplayer -v -v -frames 1 -vo mga -nosound Robotica_720.wmv > log.mga 2>&1"

comment:2 Changed 14 years ago by pub_br_mplayerhq.hu@…

mga: picture gets wrapped as described

Changed 14 years ago by pub_br_mplayerhq.hu@…

Output of "mplayer -v -v -frames 1 -vo xv -nosound Robotica_720.wmv > log.xv 2>&1"

comment:3 Changed 14 years ago by pub_br_mplayerhq.hu@…

xv: crashes and hangs (kill -9 necessary)

Changed 14 years ago by pub_br_mplayerhq.hu@…

Output of "mplayer -v -v -frames 1 -vo sdl -nosound Robotica_720.wmv > log.sdl 2>&1"

comment:4 Changed 14 years ago by pub_br_mplayerhq.hu@…

sdl: crashes

Changed 14 years ago by pub_br_mplayerhq.hu@…

Output of "mplayer -v -v -frames 1 -vo x11 -nosound Robotica_720.wmv > log.x11 2>&1"

comment:5 Changed 14 years ago by pub_br_mplayerhq.hu@…

x11: running fine (but very slow)

comment:6 Changed 14 years ago by pub_br_mplayerhq.hu@…

While trying other HDTV videos in WMV format, I noticed the following:
the original content of the left and right fourths can be faintly seen,
e.g. when the false left fourth shows a blue sky where there should be
green trees in that fourth, you can faintly see yellow trees in the
left fourth.

I used


<http://download.microsoft.com/download/a/d/6/ad6fc147-e95f-4ffd-a2e8-cbd09ca91b00/Amazon_720.exe>

for this example.

comment:7 Changed 14 years ago by pub_br_mplayerhq.hu@…

Additional information: I used the latest codecs package,
namely

essential-20041107.

mplayer 1.0pre6 was compiled using

./configure --enable-largefiles --enable-gui && make

comment:8 Changed 14 years ago by reimar

Please, those samples are much too big, and as they are zipped downloading just
part of it won't work either. Please provided them uncompressed, at least a part
of the files that shows the problem. You can e.g. upload to the ftp server...

comment:9 Changed 14 years ago by pub_br_mplayerhq.hu@…

Embarrasing, I forgot my flat rate - which happens very rarely.

Two samples can be found here:

<ftp://mplayerhq.hu/MPlayer/incoming/hdtv-mga-problems/HDTV-amazon-sample.wmv>
<ftp://mplayerhq.hu/MPlayer/incoming/hdtv-mga-problems/HDTV-robotica-sample.wmv>

I actually wanted to create them using e.g.

mplayer -ss 00:00:04 -frames 10 -dumpstream

but mplayer didn't honor "-ss" and "-frames", but dumped
the whole file instead. Should that be reported as a bug?

I created them using "dd if=... of=... bs=1k count=1000/1500"
instead.

comment:10 Changed 14 years ago by reimar

Thanks. Although I found out I actually could use zip -FF to get partial files
from the original location, too.
-ss and -frames can only work when decoding. You might have been able to get
something similar this with mencoder, but dd is better if the resulting files
still work (mov usually breaks because its index etc are at the end of the file).
I can't reproduce any of your problems here (On a Geforce3, with xv, x11, gl,
gl2 and sdl). I would guess that the problem with sdl is because it tries to use xv.
Maybe you can check xvinfo if xv supports such high resolutions. You might also
try if inserting a scale filter first to scale down fixes the problems (and
which of them it fixes).
And just to see if I understood you problem with the mga vo correctly: You get a
correct middle part but the left and right borders of the video are exchanged?

comment:11 Changed 14 years ago by pub_br_mplayerhq.hu@…

Reimar Döffinger wrote on 2004-12-27 14:36 CEST:

[mplayer -ss ... -frames ... -dumpstream]

-ss and -frames can only work when decoding.

Oh, okay!

You might have been able to get something similar this with mencoder,
but dd is better if the resulting files still work (mov usually breaks
because its index etc are at the end of the file).

dd'ing in the middle didn't work for the WMV files, I had to start from
the beginning.

I can't reproduce any of your problems here (On a Geforce3, with xv,
x11,

(x11 worked fine on my setup)

gl, gl2 and sdl). I would guess that the problem with sdl is
because it tries to use xv.

Okay, so that it seems to be either a problem of the mga/xmga driver
or a hardware problem (G450 not capable of 1280x720 videos).

Maybe you can check xvinfo if xv supports such high resolutions.

Ooops, it doesn't seem to do so:

maximum XvImage? size: 1024 x 1024

Is that due to my XFree86 4.1.0? Do I need to recompile it or can
it be configured somehow without recompilation? If I need to compile
it, I would try the latest version from X.org, namely 6.8.1.

You might also try if inserting a scale filter first to scale down
fixes the problems (and which of them it fixes).

The smaller I scale it (width), the narrower the falsely overlayed
video parts get (both left and right). With

mplayer -nosound Robotica_720.wmv -vf scale=1025:720

there are still tiny stripes with the wrong overlays on the left
and right border, and with

mplayer -nosound Robotica_720.wmv -vf scale=1024:720

it seems to work flawlessly!

What can one conclude from this?

And just to see if I understood you problem with the mga vo correctly:
You get a correct middle part but the left and right borders of the
video are exchanged?

Exactly. The original right border (about 256 pixels) is nearly totally
overlayed (intensity-wise) by a copy of the left border. The original
border only faintly shines through this overlay.

The same is true for the left border, but 1) it is about 260 pixels
wide, and 2) there is a vertical 1(?)-pixel wide stripe at about the
257th pixel, the content of which I cannot associate.

So each line looks like this:

RRRRRRRR|RMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMLLLLLLLL

R = content of right border (256 pixels, then stripe, then about 3 pixels)
| = 1-pixel-stripe of unknown content (but obviously from somewhere

out of the current picture)

M = middle part
L = content of the left border, 256 pixels wide)

comment:12 Changed 14 years ago by reimar

(In reply to comment #11)

Maybe you can check xvinfo if xv supports such high resolutions.

Ooops, it doesn't seem to do so:

maximum XvImage? size: 1024 x 1024

Is that due to my XFree86 4.1.0? Do I need to recompile it or can
it be configured somehow without recompilation? If I need to compile
it, I would try the latest version from X.org, namely 6.8.1.

You might also try if inserting a scale filter first to scale down
fixes the problems (and which of them it fixes).

The smaller I scale it (width), the narrower the falsely overlayed
video parts get (both left and right). With

mplayer -nosound Robotica_720.wmv -vf scale=1025:720

there are still tiny stripes with the wrong overlays on the left
and right border, and with

mplayer -nosound Robotica_720.wmv -vf scale=1024:720

it seems to work flawlessly!

What can one conclude from this?

From these two things together I conclude that you graphics card really isn't
able to do overlay with resolution > 1024. If I am right there isn't much you
can do - either scale down the movie or use some other vo that doesn't use
overlay (anything except (x)mga and and xv). See -vo help, some need root
permission to work.

comment:13 Changed 14 years ago by dominik@…

  • Resolution set to invalid
  • Status changed from new to closed

Not a bug then, but rather hardware limitation. Closing.

Note: See TracTickets for help on using tickets.