Opened 9 years ago

Closed 9 years ago

#1818 closed defect (duplicate)

flv muxer has arithmatic exception on i7

Reported by: compn Owned by: reimar
Priority: normal Component: ve
Version: HEAD Severity: normal
Keywords: Cc: cehoyos
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

cpu: i7 950

Reading symbols from /usr/local/bin/mencoder...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/local/bin/mencoder /home/xmobitube/invalid/1288870531-4-kh-destined-for-love-02-h264-6d60879a.mkv -o /home/xmobitube/converted/1288870531-4-kh-destined-for-love-02-h264-6d60879a.flv -vf scale=456:362,harddup -ofps 25 -of lavf -oac mp3lame -lameopts abr:br=56 -srate 22050 -ovc lavc -lavcopts vcodec=flv:vbitrate=450:vqmax=31:vqmin=2:mbd=2:mv0:trell:v4mv:cbp:last_pred=3
warning: .dynamic section for "/usr/lib/liba52.so.0" is not at the expected address
warning: difference appears to be caused by prelink, adjusting expectations
[Thread debugging using libthread_db enabled]
MEncoder SVN-r32279-4.1.2 (C) 2000-2010 MPlayer Team
success: format: 0 data: 0x0 - 0x11d357f1
libavformat file format detected.
[matroska,webm @ 0x8f8e850] max_analyze_duration reached
[matroska,webm @ 0x8f8e850] Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: video (h264), -vid 0, Destined For Love 2 (h264)
[lavf] stream 1: audio (vorbis), -aid 0, -alang jpn
[lavf] stream 2: audio (vorbis), -aid 1, -alang eng
[lavf] stream 3: subtitle (unknown), -sid 0, -slang eng, ass
VIDEO: [H264] 640x480 0bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:44 fourcc:0x34363248 size:640x480 fps:23.976 ftime:=0.0417
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, s16le, 0.0 kbit/0.00% (ratio: 0->192000)
Selected audio codec: [ffvorbis] afm: ffmpeg (FFmpeg Vorbis)
==========================================================================
MUXER_LAVF *
REMEMBER: MEncoder's libavformat muxing is presently broken and can generate
INCORRECT files in the presence of B-frames. Moreover, due to bugs MPlayer
will play these INCORRECT files as if nothing were wrong!
*
OK, exit.
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
Opening video filter: [harddup]
Opening video filter: [scale w=456 h=362]
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
MP3 audio selected.
Pos: 0.0s 1f ( 0%) 0.00fps Trem: 0min 0mb A-V:0.000 [0:0]

1 duplicate frame(s)!
VIDEO CODEC ID: 22
AUDIO CODEC ID: 15001, TAG: 0
Writing header...
[flv @ 0x88ae540]dimensions not set

Program received signal SIGFPE, Arithmetic exception.

(gdb) bt
#0 0x0867ddd7 in divdi3 ()
#1 0x082b611b in av_frac_add (f=0x8e8a8f0, incr=<value optimized out>) at utils.c:106
#2 0x082b8ae4 in compute_pkt_fields2 (s=0x91ccc10, st=0x8e8a8d0, pkt=0xbfffe564) at utils.c:2858
#3 0x082ba16f in av_interleaved_write_frame (s=0x91ccc10, pkt=0xbfffe564) at utils.c:2978
#4 0x08096512 in write_chunk (stream=0x8e8a800, len=26, flags=<value optimized out>, dts=0, pts=0) at libmpdemux/muxer_lavf.c:271
#5 0x0808a610 in muxer_write_chunk (s=0x8e8a800, len=0, flags=0, dts=-9.2233720368547758e+18, pts=-9.2233720368547758e+18) at libmpdemux/muxer.c:142
#6 0x080855f6 in main (argc=Cannot access memory at address 0x0 ) at mencoder.c:1541

Change History (4)

comment:1 Changed 9 years ago by compn

sample in incoming/bug1818.mkv

comment:2 Changed 9 years ago by cehoyos

  • Cc cehoyos@… added

Sample moved to /samples/mplayer-bugs/issue1818

comment:3 Changed 9 years ago by compn

btw i couldnt reproduce this , also the guy who reported it said it worked on another box. so no clue. i'm guessing a permission problem on his file.

comment:4 Changed 9 years ago by compn

  • Resolution set to duplicate
  • Status changed from new to closed

another dup of bug 1337 (which has a patch attached to it)

Note: See TracTickets for help on using tickets.