Opened 9 years ago

Closed 9 years ago

#1819 closed defect (worksforme)

Can not convert image files to raw avi or X264 using MEncoder in win

Reported by: happymover@… Owned by: reimar
Priority: important Component: ve
Version: 1.0rc3 Severity: blocker
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Using MEncoder, I can convert a raw avi(build by AE) to X264.
But when I try to convert image files derectly to X264 by MEncoder, it doesnt work, no imge file can be convert to X264.

And I have tried on a WinXp? PC, get a same result.

#Details=========================================================================
1, Environment: win7 X86 Intel Dual Core (Thinkpad 201)
2, MEncoder 1.0RC3 (r32492) P4-mt
3, JPG(800*600) image files sequence
==============================================================================
4, Convert to AVI(raw)
I use the command copy from man page, but get a avi file which only 5k bytes, no image is converted to the avi files.
#Command:
mencoder mf://"D:\work\*.jpeg" -mf w=800:h=600:fps=25:type=jpg -ovc copy -oac copy -o "D:\work\302.avi"

#Screen putput
MEncoder SVN-r32492-4.2.5 (C) 2000-2010 MPlayer Team
159 audio & 355 video codecs
success: format: 16 data: 0x0 - 0x0
MF file format detected.
[mf] search expr: D:\work\*.jpeg
[mf] number of files: 240 (960)
VIDEO: [IJPG] 800x600 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:16 fourcc:0x47504A49 size:800x600 fps:25.000 ftime:=0.0400
videocodec: framecopy (800x600 24bpp fourcc=47504a49)
Writing index...
Writing header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.

Video stream: nan kbit/s (-2147483648 B/s) size: 0 bytes 0.000 secs 0 frames

==============================================================================
5, Convert to X264
When I try to convert these image files to X264, I get the 5k files again, still no image is converted.

#Command:
mencoder mf://"D:\work\*.jpeg" -mf w=800:h=600:fps=25:type=jpg -ovc x264 -ffourCC H264 -x264encopts bitrate=5000:threads=auto:pass=1 -oac copy -o "D:\work\303.avi"

#Screen putput
MEncoder SVN-r32492-4.2.5 (C) 2000-2010 MPlayer Team
159 audio & 355 video codecs
success: format: 16 data: 0x0 - 0x0
MF file format detected.
[mf] search expr: D:\work\*.jpeg
[mf] number of files: 240 (960)
VIDEO: [IJPG] 800x600 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:16 fourcc:0x47504A49 size:800x600 fps:25.000 ftime:=0.0400
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffmjpeg] vfm: ffmpeg (FFmpeg MJPEG)
==========================================================================
Forcing output FourCC to 34363248 [H264].

Flushing video frames.
Filters have not been configured! Empty file?
Writing index...
Writing header...
ODML: Aspect information not (yet?) available or unspecified, not writing vprp header.

Video stream: nan kbit/s (-2147483648 B/s) size: 0 bytes 0.000 secs 0 frames

Attachments (1)

pic_02__0.jpeg (87.7 KB) - added by happymover@… 9 years ago.
one of my jpg file

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by happymover@…

one of my jpg file

comment:1 Changed 9 years ago by happymover@…

  • Priority changed from normal to important
  • Severity changed from critical to blocker

comment:2 Changed 9 years ago by compn

  • Cc patriotact@… added

workaround : try ffmpeg to convert them

comment:3 Changed 9 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed

works for me btw. try being in your d:\work dir before doing mf://*jpg . it might make a difference. also try putting the mf://*.jpg at the very end of the command line.

D:\>mencoder -mf w=800:h=600:fps=25:type=jpg -ovc x264 -ffourCC H264 -x264encopts bitrate=5000:threads=auto:pass=1 -oac copy -o crap.avi mf://pic_02__0.jpeg,pic_02__0.jpeg,pic_02__0.jpeg,pic_02__0.jpeg,pic_02__0.jpeg,pic_02__0.jpeg,pic_02__0.jpeg

MEncoder Sherpya-SVN-r32492-4.2.5 (C) 2000-2010 MPlayer Team
161 audio & 353 video codecs
success: format: 16 data: 0x0 - 0x0
MF file format detected.
[mf] filelist: pic_020.jpeg,pic_020.jpeg,pic_020.jpeg,pic_020.jpeg,pic_020.jpeg,pic_020
.jpeg,pic_020.jpeg
[mf] number of files: 7
VIDEO: [IJPG] 800x600 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
[V] filefmt:16 fourcc:0x47504A49 size:800x600 fps:25.000 ftime:=0.0400
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffmjpeg] vfm: ffmpeg (FFmpeg MJPEG)
==========================================================================
Forcing output FourCC to 34363248 [H264].
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
Movie-Aspect is undefined - no prescaling applied.
[swscaler @ 0114e074]using unscaled yuv420p -> yuv420p special converter
x264 [info]: using SAR=1/1
x264 [info]: using cpu capabilities: MMX2 SSE2 Cache64
x264 [info]: profile Main, level 3.1
Movie-Aspect is undefined - no prescaling applied.
Fontconfig error: Cannot load default config file
Fontconfig failed to select a font. Trying without fontconfig...
Fontconfig failed to select a font. Trying without fontconfig...
Pos: 0.0s 1f (15%) 0.00fps Trem: 0min 0mb A-V:0.000 [0:0]
Movie-Aspect is undefined - no prescaling applied.
Movie-Aspect is undefined - no prescaling applied.
Pos: 0.0s 2f (33%) 0.00fps Trem: 0min 0mb A-V:0.000 [0:0]
Movie-Aspect is undefined - no prescaling applied.
Movie-Aspect is undefined - no prescaling applied.
Pos: 0.0s 3f (50%) 0.00fps Trem: 0min 0mb A-V:0.000 [0:0]
Movie-Aspect is undefined - no prescaling applied.
Movie-Aspect is undefined - no prescaling applied.
Pos: 0.0s 4f (66%) 0.00fps Trem: 0min 0mb A-V:0.000 [0:0]
Movie-Aspect is undefined - no prescaling applied.
Movie-Aspect is undefined - no prescaling applied.
Pos: 0.0s 5f (82%) 0.00fps Trem: 0min 0mb A-V:0.000 [0:0]
Movie-Aspect is undefined - no prescaling applied.
Movie-Aspect is undefined - no prescaling applied.
Pos: 0.0s 6f (100%) 0.00fps Trem: 0min 0mb A-V:0.000 [0:0]
Movie-Aspect is undefined - no prescaling applied.
Movie-Aspect is undefined - no prescaling applied.
Pos: 0.0s 7f (100%) 0.00fps Trem: 0min 0mb A-V:0.000 [0:0]

Flushing video frames.
Writing header...
ODML: vprp aspect is 4:3.
Writing header...
ODML: vprp aspect is 4:3.
Writing index...
Writing header...
ODML: vprp aspect is 4:3.

Video stream: 2980.857 kbit/s (372607 B/s) size: 104330 bytes 0.280 secs 7 frames
x264 [info]: frame I:1 Avg QP:12.01 size:103914
x264 [info]: frame P:2 Avg QP:15.74 size: 86
x264 [info]: frame B:4 Avg QP:15.22 size: 61
x264 [info]: consecutive B-frames: 0.0% 33.3% 0.0% 66.7%
x264 [info]: mb I I16..4: 53.2% 0.0% 46.8%
x264 [info]: mb P I16..4: 0.0% 0.0% 0.0% P16..4: 0.9% 0.0% 0.0% 0.0% 0.0% skip:99.1%
x264 [info]: mb B I16..4: 0.0% 0.0% 0.0% B16..8: 0.1% 0.0% 0.0% direct: 0.6% skip:99.2%
L0: 9.1% L1:90.9% BI: 0.0%
x264 [info]: final ratefactor: 7.90
x264 [info]: coded y,uvDC,uvAC intra: 50.5% 51.5% 47.8% inter: 0.1% 0.4% 0.0%
x264 [info]: i16 v,h,dc,p: 85% 5% 8% 2%
x264 [info]: i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 20% 31% 16% 3% 6% 3% 6% 4% 11%
x264 [info]: i8c dc,h,v,p: 62% 18% 16% 3%
x264 [info]: Weighted P-Frames: Y:0.0%
x264 [info]: kb/s:2980.86

D:\>dir crap.avi

Volume in drive D has no label.
Volume Serial Number is F827-A4D6

Directory of D:\

12/15/2010 02:34p 108,614 crap.avi

1 File(s) 108,614 bytes
0 Dir(s) 19,493,896,192 bytes free

D:\>mplayer crap.avi
Warning unknown option capture at line 2
MPlayer Sherpya-SVN-r32492-4.2.5 (C) 2000-2010 MPlayer Team
161 audio & 353 video codecs

Playing crap.avi.
AVI file format detected.
[aviheader] Video stream found, -vid 0
AVI: No audio stream found -> no sound.
VIDEO: [H264] 800x600 24bpp 25.000 fps 2980.9 kbps (363.9 kbyte/s)
Clip info:

Software: MEncoder Sherpya-SVN-r32492-4.2.5

Opening video filter: [scale]
Opening video filter: [eq]
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
Audio: no sound
Starting playback...
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
[swscaler @ 0127cab4]using unscaled yuv420p -> yuv420p special converter
VO: [directx] 800x600 => 800x600 Planar YV12
Fontconfig error: Cannot load default config file
Fontconfig failed to select a font. Trying without fontconfig...
Fontconfig failed to select a font. Trying without fontconfig...
V: 0.2 7/ 7 ??% ??% ??,?% 0 0

Exiting... (End of file)

D:\>

Note: See TracTickets for help on using tickets.