Opened 8 years ago

Closed 8 years ago

#1824 closed defect (invalid)

8bit interplay videos are black screen

Reported by: compn Owned by: reimar
Priority: normal Component: vd
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

works in ffplay. 16bit sample works too.

Change History (1)

comment:1 Changed 8 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

Codec requires palette_control, which is deprecated and not support by MPlayer.
The reason for that is that it does not work properly with any multithreaded and/or buffering player, this in particularly means that it does not work properly in ffplay either (palette changes usually result in one frame that is wrong).
Issue is in libavcodec using deprecated and broken APIs, patches to fix probably exist already but so far always got stuck in bike-shedding with people complaining but not offering any working solution (and sometimes insisting on a non-working one).

Note: See TracTickets for help on using tickets.