Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1826 closed defect (fixed)

Green stripe in xvidix on Radeon 9200SE

Reported by: alessandro_pezzoni@… Owned by: reimar
Priority: normal Component: vo
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

System: MPlayer SVN-r32492-4.5.1 (C) 2000-2010 MPlayer Team

CPU vendor name: GenuineIntel? max cpuid level: 2
CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 2, Stepping: 9)
VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 SE]


"lspci -vvv" output attached.

Problem: When playing any kind of video file with -vo xvidix mplayer displays

an odd green vertical bar on the right.

I found an old patch [1] posted on MPlayer-dev about this same bug, but it
dooesn't seem to work anymore and being no programmer I don't know how to look
into this by myself.

Regards,
Alessandro

[1] http://www.itdp.de/mplayer-dev-eng/2004-06/msg00344.html

Attachments (1)

lspci_vvv.txt (9.8 KB) - added by alessandro_pezzoni@… 8 years ago.
"lspci -vvv" output

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by alessandro_pezzoni@…

"lspci -vvv" output

comment:1 Changed 8 years ago by reimar

It's probably something like below, however I do not know which one exactly needs to be changed. lspci -n would help there, or just try it out.
Note that for yourself you can just add it to all, but I'd really like to know which one specifically is your model so it can be documented properly.
Index: vidix/radeon_vid.c
===================================================================
--- vidix/radeon_vid.c (revision 32659)
+++ vidix/radeon_vid.c (working copy)
@@ -394,7 +394,7 @@

{ DEVICE_ATI_RADEON_R250_LG, R_250|R_OVL_SHIFT },
{ DEVICE_ATI_RV250_RADEON_9000, R_250|R_OVL_SHIFT },
{ DEVICE_ATI_RADEON_RV250_RADEON2, R_250|R_OVL_SHIFT },

  • { DEVICE_ATI_RV280_RADEON_9200, R_280 },

+ { DEVICE_ATI_RV280_RADEON_9200, R_280|R_OVL_SHIFT },

{ DEVICE_ATI_RV280_RADEON_92002, R_280 },
{ DEVICE_ATI_RV280_RADEON_92003, R_280 },
{ DEVICE_ATI_RV280_RADEON_92004, R_280 },

comment:2 Changed 8 years ago by alessandro_pezzoni@…

This worked.
It looks like my model is the one marked by "DEVICE_ATI_RV280_RADEON_92007".
For the sake of completeness:

$ lspci -n | grep 0300
01:00.0 0300: 1002:5964 (rev 01)

Thank you very much,
Alessandro

comment:3 Changed 8 years ago by alessandro_pezzoni@…

  • Resolution set to fixed
  • Status changed from new to closed

Sorry, I forgot to edit the bug's status.

comment:4 Changed 8 years ago by reimar

I have one corresponding to DEVICE_ATI_RV280_RADEON_92006 and it shows the same behaviour.
So I added this to all R280 cards in SVN r32663 since it seems somewhat likely that all behave like this.

Note: See TracTickets for help on using tickets.