Opened 9 years ago

Last modified 8 years ago

#1832 closed defect (duplicate)

mencoder crashing in swscale for some videos

Reported by: rectalogic@… Owned by: reimar
Priority: normal Component: mencoder
Version: HEAD Severity: major
Keywords: Cc: diego@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

I have a couple of samples where mencoder is crashing when encoding to raw MOV using lavf. mencoder log attached, along with gdb backtrace and valgrind log.

From the valgrind log it looks like swscale is reading off the end of a packet.

Sample uploaded to incoming/swscale-crash/mpeg1-crash.mpg

Command line used was:

mencoder -v mpeg1-crash.mpg -of lavf -lavfopts format=mov -ovc raw -vf format=uyvy -ffourcc 2vuy -sws 9 -nosound -o t.mov

Change History (1)

comment:1 Changed 8 years ago by diego@…

  • Component changed from ve to mencoder
  • Resolution set to duplicate
  • Status changed from new to closed, diego@biurrun.de

This is a duplicate.

Note: See TracTickets for help on using tickets.