Opened 8 years ago

Closed 8 years ago

#1866 closed defect (duplicate)

Build error with libpng1.5.0

Reported by: perojohn@… Owned by: diego@…
Priority: normal Component: build system
Version: 1.0rc4 Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Compiling MPlayer-1.0rc4 with libpng-1.5.0 fails with the following error:
libmpcodecs/vd_mpng.c: In function 'pngReadFN':
libmpcodecs/vd_mpng.c:77:19: error: dereferencing pointer to incomplete type
libmpcodecs/vd_mpng.c: In function 'decode':
libmpcodecs/vd_mpng.c:114:14: error: dereferencing pointer to incomplete type
libmpcodecs/vd_mpng.c:131:87: error: dereferencing pointer to incomplete type
make: * [libmpcodecs/vd_mpng.o] Error 1

Compile of MPlayer-1.0rc4 succeeds with libpng-1.4.5
Note also that the latest code from svn compiles fine with libpng-1.5.0

Change History (1)

comment:1 Changed 8 years ago by diego@…

  • Resolution set to duplicate
  • Status changed from new to closed

Marking as duplicate of the bug with patch attached.

Note: See TracTickets for help on using tickets.