Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#189 closed defect (duplicate)

make[1]: *** [ao_alsa.o] Error 1

Reported by: semicide@… Owned by: alex@…
Priority: normal Component: ao
Version: 1.0pre6 Severity: critical
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Although alsa is installed and identified properly for use during ./configure,
make refuses to build with the following message:


feynman:/usr/local/MPlayer-1.0pre6a # make
make -C libao2
make[1]: Entering directory `/usr/local/MPlayer-1.0pre6a/libao2'
cc -c -I../libvo -I../../libvo -I/usr/X11/include -fno-PIC -O4 -march=i686
-mcpu=i686 -pipe -ffast-math -fomit-frame-pointer -D_REENTRANT
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -I. -I..

-I/usr/include/SDL -D_REENTRANT -I/usr/X11/include -I/usr/include/gtk-1.2

-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -o
ao_alsa.o ao_alsa.c
ao_alsa.c: In function `init':
ao_alsa.c:615: warning: passing arg 3 of `snd_pcm_hw_params_set_rate_near' makes
integer from pointer without a cast
ao_alsa.c:653: warning: passing arg 3 of
`snd_pcm_hw_params_set_period_size_near' makes integer from pointer without a cast
ao_alsa.c:662: warning: passing arg 3 of `snd_pcm_hw_params_set_periods_near'
makes integer from pointer without a cast
ao_alsa.c:682: too many arguments to function `snd_pcm_hw_params_get_buffer_size'
make[1]: * [ao_alsa.o] Error 1
make[1]: Leaving directory `/usr/local/MPlayer-1.0pre6a/libao2'
make:
* [libao2/libao2.a] Error 2


I can also forward the complete output of configure, configure.log, and whatever
else you might need me to collect.

Thanks & Best Regards,
Steve

Attachments (2)

configure.txt (8.9 KB) - added by semicide@… 14 years ago.
output of command ./configure --enable-gui
configure.log (127.6 KB) - added by semicide@… 14 years ago.
./configure --enable-gui logging output

Download all attachments as: .zip

Change History (6)

Changed 14 years ago by semicide@…

output of command ./configure --enable-gui

comment:1 Changed 14 years ago by semicide@…

Changed 14 years ago by semicide@…

./configure --enable-gui logging output

comment:2 Changed 14 years ago by semicide@…

comment:3 Changed 14 years ago by reimar

  • Resolution set to duplicate
  • Status changed from new to closed

Your alsa version is too old, versions older that 0.9.0rc4 are not supported.

* This bug has been marked as a duplicate of 58 *

comment:4 Changed 14 years ago by reimar

You can also add --disable-alsa to the configure line and use e.g. ALSA's OSS
emulation, it works better for most anyway...

Note: See TracTickets for help on using tickets.