Opened 9 years ago

Closed 9 years ago

#1908 closed defect (fixed)

build error on os x

Reported by: normanmacintyre@… Owned by: reimar
Priority: normal Component: vd
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

mplayer has not built on os x 10.6 since 4/17.

libmpcodecs/vd_ffmpeg.c: In function 'init':
libmpcodecs/vd_ffmpeg.c:425: warning: 'AVPaletteControl' is deprecated
libmpcodecs/vd_ffmpeg.c: In function 'get_buffer':
libmpcodecs/vd_ffmpeg.c:609: error: 'AVCodecContext' has no member named 'hurry_up'
libmpcodecs/vd_ffmpeg.c:615: error: 'AVCodecContext' has no member named 'hurry_up'
libmpcodecs/vd_ffmpeg.c: In function 'decode':
libmpcodecs/vd_ffmpeg.c:832: error: 'AVCodecContext' has no member named 'hurry_up'
libmpcodecs/vd_ffmpeg.c:921: warning: return discards qualifiers from pointer target type
make: * [libmpcodecs/vd_ffmpeg.o] Error 1

Change History (1)

comment:1 Changed 9 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

FFmpeg had a major API change, caused some issues.
Fixed, since today even when building against a system FFmpeg (even though that's not exactly recommended/supported anyway).

Note: See TracTickets for help on using tickets.