Opened 8 years ago

Closed 8 years ago

#1909 closed defect (invalid)

(SVN-r33299) MPlayer linking failed on libswscale references

Reported by: godsic@… Owned by: diego@…
Priority: very important Component: build system
Version: HEAD Severity: critical
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Linking failed on:

cc -o mplayer command.o m_property.o mixer.o mp_fifo.o mplayer.o parser-mpcmd.o pnm_loader.o input/input.o libao2/ao_mpegpes.o libao2/ao_null.o libao2/ao_pcm.o libao2/audio_out.o libvo/aspect.o libvo/geometry.o libvo/video_out.o libvo/vo_mpegpes.o libvo/vo_null.o sub/spuenc.o libao2/ao_alsa.o input/appleir.o libvo/vo_dga.o libvo/vo_directfb2.o libvo/vo_dfbmga.o libvo/vo_fbdev.o libvo/vo_fbdev2.o libvo/vo_png.o libvo/vo_gif89a.o libvo/gl_common.o libvo/vo_gl.o libvo/vo_gl2.o libvo/csputils.o libvo/sdl_common.o libvo/x11_common.o libvo/vo_matrixview.o libvo/matrixview.o libao2/ao_jack.o libvo/vo_jpeg.o libvo/vo_md5sum.o udp_sync.o libao2/ao_oss.o libvo/vo_pnm.o libao2/ao_pulse.o libao2/ao_sdl.o libvo/vo_sdl.o libvo/vo_tga.o libvo/vo_v4l2.o libao2/ao_v4l2.o libvo/vo_cvidix.o libvo/vosub_vidix.o vidix/vidix.o vidix/drivers.o vidix/dha.o vidix/mtrr.o vidix/pci.o vidix/pci_names.o vidix/pci_dev_ids.o vidix/cyberblade_vid.o vidix/mach64_vid.o vidix/mga_vid.o vidix/mga_crtc2_vid.o vidix/nvidia_vid.o vidix/pm2_vid.o vidix/pm3_vid.o vidix/radeon_vid.o vidix/rage128_vid.o vidix/s3_vid.o vidix/sis_vid.o vidix/sis_bridge.o vidix/unichrome_vid.o libvo/vo_x11.o libvo/vo_xover.o libvo/vo_xv.o libvo/vo_xvidix.o libvo/vo_yuv4mpeg.o asxparser.o bstr.o codec-cfg.o cpudetect.o edl.o fmt-conversion.o m_config.o m_option.o m_struct.o mp_msg.o mp_strings.o mpcommon.o parser-cfg.o path.o playtree.o playtreeparser.o subopt-helper.o libaf/af.o libaf/af_center.o libaf/af_channels.o libaf/af_comp.o libaf/af_delay.o libaf/af_dummy.o libaf/af_equalizer.o libaf/af_extrastereo.o libaf/af_format.o libaf/af_gate.o libaf/af_hrtf.o libaf/af_karaoke.o libaf/af_pan.o libaf/af_resample.o libaf/af_scaletempo.o libaf/af_sinesuppress.o libaf/af_stats.o libaf/af_sub.o libaf/af_surround.o libaf/af_sweep.o libaf/af_tools.o libaf/af_volnorm.o libaf/af_volume.o libaf/filter.o libaf/format.o libaf/reorder_ch.o libaf/window.o libmpcodecs/ad.o libmpcodecs/ad_alaw.o libmpcodecs/ad_dk3adpcm.o libmpcodecs/ad_dvdpcm.o libmpcodecs/ad_hwac3.o libmpcodecs/ad_hwmpa.o libmpcodecs/ad_imaadpcm.o libmpcodecs/ad_msadpcm.o libmpcodecs/ad_pcm.o libmpcodecs/dec_audio.o libmpcodecs/dec_teletext.o libmpcodecs/dec_video.o libmpcodecs/img_format.o libmpcodecs/mp_image.o libmpcodecs/pullup.o libmpcodecs/vd.o libmpcodecs/vd_hmblck.o libmpcodecs/vd_lzo.o libmpcodecs/vd_mpegpes.o libmpcodecs/vd_mtga.o libmpcodecs/vd_null.o libmpcodecs/vd_raw.o libmpcodecs/vd_sgi.o libmpcodecs/vf.o libmpcodecs/vf_1bpp.o libmpcodecs/vf_2xsai.o libmpcodecs/vf_blackframe.o libmpcodecs/vf_boxblur.o libmpcodecs/vf_crop.o libmpcodecs/vf_cropdetect.o libmpcodecs/vf_decimate.o libmpcodecs/vf_delogo.o libmpcodecs/vf_denoise3d.o libmpcodecs/vf_detc.o libmpcodecs/vf_dint.o libmpcodecs/vf_divtc.o libmpcodecs/vf_down3dright.o libmpcodecs/vf_dsize.o libmpcodecs/vf_dvbscale.o libmpcodecs/vf_eq.o libmpcodecs/vf_eq2.o libmpcodecs/vf_expand.o libmpcodecs/vf_field.o libmpcodecs/vf_fil.o libmpcodecs/vf_filmdint.o libmpcodecs/vf_fixpts.o libmpcodecs/vf_flip.o libmpcodecs/vf_format.o libmpcodecs/vf_framestep.o libmpcodecs/vf_gradfun.o libmpcodecs/vf_halfpack.o libmpcodecs/vf_harddup.o libmpcodecs/vf_hqdn3d.o libmpcodecs/vf_hue.o libmpcodecs/vf_il.o libmpcodecs/vf_ilpack.o libmpcodecs/vf_ivtc.o libmpcodecs/vf_kerndeint.o libmpcodecs/vf_mirror.o libmpcodecs/vf_noformat.o libmpcodecs/vf_noise.o libmpcodecs/vf_ow.o libmpcodecs/vf_palette.o libmpcodecs/vf_perspective.o libmpcodecs/vf_phase.o libmpcodecs/vf_pp7.o libmpcodecs/vf_pullup.o libmpcodecs/vf_rectangle.o libmpcodecs/vf_remove_logo.o libmpcodecs/vf_rgbtest.o libmpcodecs/vf_rotate.o libmpcodecs/vf_sab.o libmpcodecs/vf_scale.o libmpcodecs/vf_smartblur.o libmpcodecs/vf_softpulldown.o libmpcodecs/vf_stereo3d.o libmpcodecs/vf_softskip.o libmpcodecs/vf_swapuv.o libmpcodecs/vf_telecine.o libmpcodecs/vf_test.o libmpcodecs/vf_tfields.o libmpcodecs/vf_tile.o libmpcodecs/vf_tinterlace.o libmpcodecs/vf_unsharp.o libmpcodecs/vf_vo.o libmpcodecs/vf_yadif.o libmpcodecs/vf_yuvcsp.o libmpcodecs/vf_yvu9.o libmpdemux/aac_hdr.o libmpdemux/asfheader.o libmpdemux/aviheader.o libmpdemux/aviprint.o libmpdemux/demuxer.o libmpdemux/demux_aac.o libmpdemux/demux_asf.o libmpdemux/demux_audio.o libmpdemux/demux_avi.o libmpdemux/demux_demuxers.o libmpdemux/demux_film.o libmpdemux/demux_fli.o libmpdemux/demux_lmlm4.o libmpdemux/demux_mf.o libmpdemux/demux_mkv.o libmpdemux/demux_mov.o libmpdemux/demux_mpg.o libmpdemux/demux_nsv.o libmpdemux/demux_pva.o libmpdemux/demux_rawaudio.o libmpdemux/demux_rawvideo.o libmpdemux/demux_realaud.o libmpdemux/demux_real.o libmpdemux/demux_roq.o libmpdemux/demux_smjpeg.o libmpdemux/demux_ts.o libmpdemux/demux_ty.o libmpdemux/demux_ty_osd.o libmpdemux/demux_viv.o libmpdemux/demux_vqf.o libmpdemux/demux_y4m.o libmpdemux/ebml.o libmpdemux/extension.o libmpdemux/mf.o libmpdemux/mp3_hdr.o libmpdemux/mp_taglists.o libmpdemux/mpeg_hdr.o libmpdemux/mpeg_packetizer.o libmpdemux/parse_es.o libmpdemux/parse_mp4.o libmpdemux/video.o libmpdemux/yuv4mpeg.o libmpdemux/yuv4mpeg_ratio.o osdep/getch2.o osdep/timer-linux.o stream/open.o stream/stream.o stream/stream_bd.o stream/stream_cue.o stream/stream_file.o stream/stream_mf.o stream/stream_null.o stream/url.o sub/eosd.o sub/find_sub.o sub/osd.o sub/spudec.o sub/sub.o sub/sub_cc.o sub/subreader.o sub/vobsub.o stream/ai_alsa1x.o stream/ai_oss.o sub/font_load.o stream/dvb_tune.o stream/stream_dvb.o stream/stream_dvdnav.o libdvdnav/dvdnav.o libdvdnav/highlight.o libdvdnav/navigation.o libdvdnav/read_cache.o libdvdnav/remap.o libdvdnav/searching.o libdvdnav/settings.o libdvdnav/vm/decoder.o libdvdnav/vm/vm.o libdvdnav/vm/vmcmd.o stream/stream_dvd.o stream/stream_dvd_common.o libdvdread4/bitreader.o libdvdread4/dvd_input.o libdvdread4/dvd_reader.o libdvdread4/dvd_udf.o libdvdread4/ifo_print.o libdvdread4/ifo_read.o libdvdread4/md5.o libdvdread4/nav_print.o libdvdread4/nav_read.o libvo/aclib.o av_opts.o libaf/af_lavcresample.o libmpcodecs/ad_ffmpeg.o libmpcodecs/vd_ffmpeg.o libmpcodecs/vf_geq.o libmpcodecs/vf_lavc.o libmpcodecs/vf_lavcdeint.o libmpcodecs/vf_pp.o libmpcodecs/vf_screenshot.o libmpdemux/demux_lavf.o stream/stream_ffmpeg.o sub/av_sub.o libaf/af_lavcac3enc.o libmpcodecs/vf_fspp.o libmpcodecs/vf_mcdeint.o libmpcodecs/vf_qp.o libmpcodecs/vf_spp.o libmpcodecs/vf_uspp.o sub/font_load_ft.o stream/stream_ftp.o libmpdemux/demux_gif.o libmpcodecs/vf_bmovl.o libaf/af_export.o osdep/mmap_anon.o libmpcodecs/vd_ijpg.o libaf/af_ladspa.o libmpcodecs/vf_ass.o sub/ass_mp.o sub/subassconvert.o libass/ass.o libass/ass_bitmap.o libass/ass_cache.o libass/ass_drawing.o libass/ass_font.o libass/ass_fontconfig.o libass/ass_library.o libass/ass_parse.o libass/ass_render.o libass/ass_render_api.o libass/ass_strtod.o libass/ass_utils.o libdvdcss/css.o libdvdcss/device.o libdvdcss/error.o libdvdcss/ioctl.o libdvdcss/libdvdcss.o libmpcodecs/vd_libmpeg2.o libmpeg2/alloc.o libmpeg2/cpu_accel.o libmpeg2/cpu_state.o libmpeg2/decode.o libmpeg2/header.o libmpeg2/idct.o libmpeg2/motion_comp.o libmpeg2/slice.o libmpeg2/idct_mmx.o libmpeg2/motion_comp_mmx.o libmpdemux/demux_mng.o libmpcodecs/ad_mp3lib.o mp3lib/sr1.o mp3lib/decode_mmx.o mp3lib/dct64_sse.o stream/stream_rtsp.o stream/freesdp/common.o stream/freesdp/errorlist.o stream/freesdp/parser.o stream/librtsp/rtsp.o stream/librtsp/rtsp_rtp.o stream/librtsp/rtsp_session.o osdep/shmem.o stream/stream_netstream.o stream/asf_mmst_streaming.o stream/asf_streaming.o stream/cookies.o stream/http.o stream/network.o stream/pnm.o stream/rtp.o stream/udp.o stream/tcp.o stream/stream_rtp.o stream/stream_udp.o stream/realrtsp/asmrp.o stream/realrtsp/real.o stream/realrtsp/rmff.o stream/realrtsp/sdpplin.o stream/realrtsp/xbuffer.o libmpcodecs/vd_mpng.o stream/stream_pvr.o libmpcodecs/ad_realaud.o libmpcodecs/vd_realvid.o stream/cache2.o tremor/bitwise.o tremor/block.o tremor/codebook.o tremor/floor0.o tremor/floor1.o tremor/framing.o tremor/info.o tremor/mapping0.o tremor/mdct.o tremor/registry.o tremor/res012.o tremor/sharedbook.o tremor/synthesis.o tremor/window.o stream/stream_tv.o stream/tv.o stream/frequencies.o stream/tvi_dummy.o stream/tvi_v4l2.o stream/audio_in.o sub/unrar_exec.o stream/stream_vcd.o libmpcodecs/ad_libvorbis.o libmpdemux/demux_ogg.o libmpcodecs/vd_xanim.o libmpcodecs/vd_xvid4.o ffmpeg/libavformat/libavformat.a ffmpeg/libavcodec/libavcodec.a ffmpeg/libavutil/libavutil.a ffmpeg/libpostproc/libpostproc.a ffmpeg/libswscale/libswscale.a -Wl,-z,noexecstack -ffast-math -lncurses -lpng -lz -lmng -lz -ljpeg -lgif -lasound -ldl -lpthread -lfreetype -lfontconfig -lz -lbz2 -lxvidcore -lm -lpthread -ldl -rdynamic -lm -ldirectfb -lXext -lX11 -lpthread -lXss -lXv -lXinerama -lXxf86vm -lXxf86dga -lSDL -lGL -ldl -lpulse -ljack -lx264 -lpthread
libvo/vo_matrixview.o: In function `draw_slice':
vo_matrixview.c:(.text+0x88): undefined reference to `sws_scale'
libvo/vo_matrixview.o: In function `uninit':
vo_matrixview.c:(.text+0x387): undefined reference to `sws_freeContext'
libvo/vo_matrixview.o: In function `config':
vo_matrixview.c:(.text+0x48b): undefined reference to `sws_freeContext'
libvo/vo_x11.o: In function `draw_slice':
vo_x11.c:(.text+0x4c6): undefined reference to `sws_freeContext'
vo_x11.c:(.text+0x543): undefined reference to `sws_scale'
libvo/vo_x11.o: In function `config':
vo_x11.c:(.text+0xe46): undefined reference to `sws_freeContext'
libvo/vo_x11.o: In function `uninit':
vo_x11.c:(.text+0xc02): undefined reference to `sws_freeContext'
libmpcodecs/vf_halfpack.o: In function `uninit':
vf_halfpack.c:(.text+0xdc0): undefined reference to `sws_freeContext'
libmpcodecs/vf_halfpack.o: In function `put_image':
vf_halfpack.c:(.text+0xeb2): undefined reference to `sws_scale'
libmpcodecs/vf_halfpack.o: In function `config':
vf_halfpack.c:(.text+0xf99): undefined reference to `sws_freeContext'
vf_halfpack.c:(.text+0xffa): undefined reference to `sws_getContext'
libmpcodecs/vf_palette.o: In function `put_image':
vf_palette.c:(.text+0x109): undefined reference to `sws_convertPalette8ToPacked32'
vf_palette.c:(.text+0x141): undefined reference to `sws_convertPalette8ToPacked24'
vf_palette.c:(.text+0x231): undefined reference to `sws_convertPalette8ToPacked32'
vf_palette.c:(.text+0x278): undefined reference to `sws_convertPalette8ToPacked24'
libmpcodecs/vf_sab.o: In function `uninit':
vf_sab.c:(.text+0x103): undefined reference to `sws_freeContext'
vf_sab.c:(.text+0x145): undefined reference to `sws_freeContext'
libmpcodecs/vf_sab.o: In function `blur':
vf_sab.c:(.text+0x328): undefined reference to `sws_scale'
libmpcodecs/vf_sab.o: In function `allocStuff':
vf_sab.c:(.text+0x82a): undefined reference to `sws_getGaussianVec'
vf_sab.c:(.text+0x88c): undefined reference to `sws_getContext'
vf_sab.c:(.text+0x898): undefined reference to `sws_freeVec'
vf_sab.c:(.text+0x8aa): undefined reference to `sws_getGaussianVec'
vf_sab.c:(.text+0x94a): undefined reference to `sws_freeVec'
vf_sab.c:(.text+0x958): undefined reference to `sws_getGaussianVec'
vf_sab.c:(.text+0x9f0): undefined reference to `sws_freeVec'
libmpcodecs/vf_scale.o: In function `uninit':
vf_scale.c:(.text+0x85): undefined reference to `sws_freeContext'
vf_scale.c:(.text+0x9a): undefined reference to `sws_freeContext'
libmpcodecs/vf_scale.o: In function `control':
vf_scale.c:(.text+0x15d): undefined reference to `sws_getColorspaceDetails'
vf_scale.c:(.text+0x1ed): undefined reference to `sws_getColorspaceDetails'
vf_scale.c:(.text+0x278): undefined reference to `sws_setColorspaceDetails'
vf_scale.c:(.text+0x2c5): undefined reference to `sws_setColorspaceDetails'
libmpcodecs/vf_scale.o: In function `scale':
vf_scale.c:(.text+0x5ca): undefined reference to `sws_scale'
vf_scale.c:(.text+0x648): undefined reference to `sws_scale'
vf_scale.c:(.text+0x695): undefined reference to `sws_scale'
libmpcodecs/vf_scale.o: In function `sws_getFlagsAndFilterFromCmdLine':
vf_scale.c:(.text+0x9f9): undefined reference to `sws_freeFilter'
vf_scale.c:(.text+0xa3b): undefined reference to `sws_getDefaultFilter'
libmpcodecs/vf_scale.o: In function `config':
vf_scale.c:(.text+0xd4d): undefined reference to `sws_freeContext'
vf_scale.c:(.text+0xd62): undefined reference to `sws_freeContext'
vf_scale.c:(.text+0xe37): undefined reference to `sws_getContext'
vf_scale.c:(.text+0x1597): undefined reference to `sws_getContext'
libmpcodecs/vf_scale.o: In function `sws_getContextFromCmdLine':
vf_scale.c:(.text+0x1bbc): undefined reference to `sws_getContext'
libmpcodecs/vf_smartblur.o: In function `uninit':
vf_smartblur.c:(.text+0x137): undefined reference to `sws_freeContext'
vf_smartblur.c:(.text+0x154): undefined reference to `sws_freeContext'
libmpcodecs/vf_smartblur.o: In function `allocStuff':
vf_smartblur.c:(.text+0x20b): undefined reference to `sws_getGaussianVec'
vf_smartblur.c:(.text+0x21b): undefined reference to `sws_scaleVec'
vf_smartblur.c:(.text+0x2a8): undefined reference to `sws_getContext'
vf_smartblur.c:(.text+0x2b4): undefined reference to `sws_freeVec'
libmpcodecs/vf_smartblur.o: In function `put_image':
vf_smartblur.c:(.text+0x567): undefined reference to `sws_scale'
vf_smartblur.c:(.text+0x705): undefined reference to `sws_scale'
vf_smartblur.c:(.text+0x888): undefined reference to `sws_scale'
sub/spudec.o: In function `spudec_draw_scaled':
spudec.c:(.text+0x2854): undefined reference to `sws_getContext'
spudec.c:(.text+0x287d): undefined reference to `sws_scale'
spudec.c:(.text+0x28e1): undefined reference to `sws_scale'
spudec.c:(.text+0x2b38): undefined reference to `sws_freeContext'
spudec.c:(.text+0x2b7a): undefined reference to `sws_freeVec'
spudec.c:(.text+0x2b9d): undefined reference to `sws_getGaussianVec'
spudec.c:(.text+0x2bc9): undefined reference to `sws_normalizeVec'
libmpcodecs/vf_screenshot.o: In function `uninit':
vf_screenshot.c:(.text+0x12e): undefined reference to `sws_freeContext'
libmpcodecs/vf_screenshot.o: In function `draw_slice':
vf_screenshot.c:(.text+0x21e): undefined reference to `sws_scale'
libmpcodecs/vf_screenshot.o: In function `put_image':
vf_screenshot.c:(.text+0x6aa): undefined reference to `sws_scale'
collect2: ld returned 1 exit status
make: * [mplayer] Error 1

Change History (4)

comment:1 Changed 8 years ago by godsic@…

  • Version changed from unspecified to HEAD

comment:2 Changed 8 years ago by godsic@…

  • Priority changed from normal to very important
  • Severity changed from normal to critical

comment:3 Changed 8 years ago by godsic@…

I've just checked the libswscale and it turns out that all objects are empty, so I assume that there is a bug in libswscale building scripts.

comment:4 Changed 8 years ago by diego@…

  • Resolution set to invalid
  • Status changed from new to closed

This is completely unreproducible and will likely go away after a 'make distclean' and/or with a fresh checkout. Also, debugging this would require more detailed information like compiler involved, compilation command lines use to compile libswscale, MPlayer revision, etc...

Note: See TracTickets for help on using tickets.