Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#193 closed enhancement (invalid)

RealNetworks RealVideo 10 (RV10)

Reported by: gamester17@… Owned by: moritz@…
Priority: normal Component: demuxer
Version: unspecified Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Not a bug but couldn't find better way to submit a request/suggestion(?):

This is a feature request for RealNetworks? RealVideo? 10 codec support,
to properly decode/playback RealMedia? 10 RMVB encoded video files/media.
(MPlayer currently detect RV10 as Realvideo 9 RV40 and fail to playback).

Suggest to base a new native codec on Helix DNA Producer 10.1.0.390
or alternativly use existing RealPlayer? 10 DLL for RV10 playback(?).

http://helix-producer.helixcommunity.org
https://www.helixcommunity.org
http://forum.doom9.org/showthread.php?s=&threadid=84142

PS! I appologuise in advance if this is the improper way to submit this.

Change History (8)

comment:1 Changed 15 years ago by reimar

  • Severity changed from normal to enhancement

(In reply to comment #0)

Not a bug but couldn't find better way to submit a request/suggestion(?):

You did it almost correctly. You should have set severity to "enhancement".

This is a feature request for RealNetworks? RealVideo? 10 codec support,
to properly decode/playback RealMedia? 10 RMVB encoded video files/media.
(MPlayer currently detect RV10 as Realvideo 9 RV40 and fail to playback).

Please provide a sample file.

Suggest to base a new native codec on Helix DNA Producer 10.1.0.390
or alternativly use existing RealPlayer? 10 DLL for RV10 playback(?).

Can you give more detailed information? All I heard is that Helix is absolutely
no help at all for supporting Real format and it can't even use the Real dlls
(they changed the format so MPlayer doesn't support them).

comment:2 Changed 15 years ago by reimar

Now, you really succeded to confuse me here. RealPlayer? 10 introduced no new
format, so there is no need to support it.
If you mean the format with FourCC RV10, that is version 1.0, and there is an
opensource decoder available.
You should really provide a sample file and make a proper bugreport!
Same applies to the RA10 entry...

comment:3 Changed 15 years ago by gamester17@…

I'm not a developer/programmer myself so if you say Helix source code or Helix
DLL's can't be used to add support for RV10 then I take your word for it =(

Though maybe you can use standard RealPlayer? 10 DLL's ( http://www.real.com )?
(RV 10 is the same as RV9-EHQ and has the FourCC code 'rv40', but they added
some special bits that identify it such that it displays RV10 in RealPlayer? 10).

Samples are available for download here:
https://helixcommunity.org/project/showfiles.php?group_id=30
http://dark.pluridis.org/trailers/
http://www.medialab.sonera.fi/demos/streaming/avq/video_real_vs_windowsmedia/

Or use "RealAnime?", "AutoRV10" or "RealBatch?" to easily encode your own samples;

"RealAnime? (Borland Delphi 7 VCL open source, licensed under GNU, uses DLL's)":
http://www.detritus.qc.ca/index.php?section=download
http://www.detritus.qc.ca/index.php?section=projects
http://forum.doom9.org/showthread.php?s=&threadid=83409

"AutoRV10":
(fullversion =>) http://dark.pluridis.org/downloads/Autorv10_v1.0.zip
(update =>) http://dark.pluridis.org/AutoRV10_v1.0_b7.1_update.zip
http://forum.doom9.org/showthread.php?s=&threadid=29077
http://www.video-tools.com
http://dark.pluridis.org/autorv10_guide/AutoRv10.htm

"RealBatch?"
http://damrod66.free.fr/site/soft.html
http://forum.doom9.org/showthread.php?s=&threadid=70926

You can use also "Real Producer Basic 10" to split (demux) audio and video =D

PS! So Helix source code is really then useless for decoding RV10 in MPlayer?:
https://player.helixcommunity.org/2004/downloads/
https://helixcommunity.org/softwaremap/trove_list.php?form_cat=306
https://helixcommunity.org/softwaremap/trove_list.php?form_cat=193
http://forum.doom9.org/showthread.php?s=&threadid=68245

Media Player Classic (MPC) can play RV10 via RealPlayer? 10 DirectShow? filter
http://sourceforge.net/projects/guliverkli Home: http://www.gabest.org/mpc.php

comment:4 Changed 15 years ago by gamester17@…

  • bug_file_loc changed from http://www.helixcommunity.org to http://forum.doom9.org/showthread.php?s=&threadid=68245

@Reimar, RV10 is a newish format, RV 10 is the same as RV9-EHQ "it even has the
same FourCC code 'rv40'. When playing RV10 in RealPlayer? 10, we added some
special bits that identify the format, such that it displays RV10. Older
players will display RV9", it's like comparing MP3 versus mp3PRO, mp3PRO will
play on older MP3 players but you will not get the full quaility of mp3PRO =P

See description here: http://forum.doom9.org/showthread.php?s=&threadid=68245

comment:5 Changed 15 years ago by gamester17@…

@Reimar, RV10 is a newish format, RV 10 is the same as RV9-EHQ "it even has the
same FourCC code 'rv40'. When playing RV10 in RealPlayer? 10, we added some
special bits that identify the format, such that it displays RV10. Older
players will display RV9", it's like comparing MP3 versus mp3PRO, mp3PRO will
play on older MP3 players but you will not get the full quaility of mp3PRO =P

See description here: http://forum.doom9.org/showthread.php?s=&threadid=68245

comment:6 Changed 15 years ago by gamester17@…

  • bug_file_loc changed from http://forum.doom9.org/showthread.php?s=&threadid=68245 to http://www.realnetworks.com/products/codecs/realvideo.html

More samples:
http://www.realnetworks.com/products/codecs/realvideo.html

PS! Many also mux RV10 from RMVB into MKV (Matroska) which can cause probems:
http://www.video-tools.com/modules.php?name=Forums&file=viewtopic&t=338

comment:7 Changed 15 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

1) You claimed "and fail to playback". I can play all samples that I tried.
2) From one of the links you gave:
RealVideo? 10:
[...]
It is an encoder side improvement, where as you know we gain quality by letting
the encoder spend more time making wise decisions.

So what do you want??? The number seems to be the only difference.
Please think and decide what you want and provide us a sample that shows the
problem. You can reopen this then.

Also Helix with all this login etc nonsense is just too much work for me to even
look at it.

comment:8 Changed 15 years ago by gamester17@…

This was only opened by me as a feature request, (not as a bug report),
...so yes I guess what I like to see is detection of the number (RV10).

Side note: I will test if I can find problem sample(s) with latest CVS.

Note: See TracTickets for help on using tickets.