Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#194 closed enhancement (worksforme)

RealNetworks RealAudio 10 (RAAC/RACP)

Reported by: gamester17@… Owned by: moritz@…
Priority: normal Component: demuxer
Version: unspecified Severity: minor
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Maybe not a bug but couldn't find better way to submit a request/suggestion(?)
This is a feature request for RealNetworks? RealAudio? 10 demuxer/codec support,
to properly demux and decode/playback RealMedia? 10 encoded audio files/media.
(MPlayer currently get "ERROR mplayer generated exception in decode_audio").

Since RA10 is based on MPEG-4 AAC I guess/hope you can use libFAAD as the base?

http://helix-producer.helixcommunity.org
https://www.helixcommunity.org
http://forum.doom9.org/showthread.php?s=&threadid=84142

PS! I appologuise in advance if this is the improper way to submit this issue.
(Note! This report is not to be confused with BUG #193 which is for RV10 video)

Attachments (1)

test.rmvb (110.7 KB) - added by wkt20@… 14 years ago.
File encoded with the RAAC-0 audio codec

Download all attachments as: .zip

Change History (12)

comment:1 Changed 14 years ago by gamester17@…

  • bug_file_loc changed from http://www.helixcommunity.org to http://forum.doom9.org/showthread.php?s=&threadid=68245
  • Severity changed from normal to enhancement

"RealAudio? 10 : This is a family of audio codecs. New codecs are AAC, RealAudio?
Lossless, and RealAudio? Multi-channel. RA8 (cook) is used for 96 kbps and
below. HE-AAC in the form of aacPlus from Coding Technologies is included on
Windows" "RealAudio? 10 aacPlus (AAC+) is the same as HE-AAC, RealProducer? wraps
AAC in RM (.ra) for RealPlayer? 10 and ADTS .aac for RealPlayer? 10 Gold"

4CC codes for the AAC codec flavors when wrapped in RM:
raac: AAC or HE-AAC
racp: HE-AAC
RealPlayer? 10's AAC decoder, raac.dll, can decode both AAC, HE-AAC and Raw ADTS

For more info see:
http://forum.doom9.org/showthread.php?s=&threadid=68245

Samples:
http://www.realnetworks.com/products/codecs/realaudio.html
https://helixcommunity.org/project/showfiles.php?group_id=30
http://dark.pluridis.org/trailers/
http://www.medialab.sonera.fi/demos/streaming/avq/video_real_vs_windowsmedia/

Aternativly encode your own samples with RealProducer? 10 or Helix Producer 10:
http://www.realnetworks.com/products/producer/index.html
https://helix-producer.helixcommunity.org/downloads

PS! As you can probebely aready can tell; I'm not not a developer/coder myself.

comment:2 Changed 14 years ago by gamester17@…

  • Summary changed from RealNetworks RealAudio 10 (RA10) to RealNetworks RealAudio 10 (RAAC/RACP)

comment:3 Changed 14 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

Same as for bug#193: All information I have indicates that at least on the
decoder side this is the same as RealAudio9, which already is supported
(although unfortunately only via binary codecs).
If you find anything that proves the opposite, reopen.

comment:4 Changed 14 years ago by reimar

And what concerns the playback problems: I works fine for me with MPlayer CVS.
Most samples actually are decoded with the opensource faad codec.
So if you have playback problems, please provide a sample (not just links to
pages that contains several samples but the one that doesn't work for you) and
make a proper bugreport (i.e. at least mplayer -v log). For detail see the
bugreports.html file.

comment:5 Changed 14 years ago by wkt20@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

I have a rmvb file that mplayer doesn't play. The information given by
AVIcodec is as follows:

Video : 204 MB, 661 Kbps, 25.0 fps, 512*384 (4:3), RV40 = RealVideo? 9
Audio : 19.77 MB, 64 Kbps, 32000 Hz, 2 channels, 0x0 = RealAudio? 8,raac-0

I think the main problem with this file lies in the raac-0 audio codec.
Mplayer was able to play files with RV40 = RealVideo? 9 and RealAudio? 8,cook-21
codecs. I would be happy to upload the files if you need it.

Changed 14 years ago by wkt20@…

File encoded with the RAAC-0 audio codec

comment:6 Changed 14 years ago by wkt20@…

This is a short rmvb file that Mplayer was unable to play.

comment:7 Changed 14 years ago by moritz@…

  • Resolution set to worksforme
  • Status changed from reopened to closed

Works here. Your mplayer binary or installation seems to be the problem.

comment:8 Changed 14 years ago by reimar

Works here with MPlayer CVS, too. It uses the faad decoder to play the audio
btw, could be that
1) your version does not yet include it
2) it was fixed recently

comment:9 Changed 14 years ago by moritz@…

Support for AAC in RM files was done by me and added a year ago:

revision 1.54
date: 2004/01/29 12:11:13; author: attila; state: Exp; lines: +37 -0
add support for aac in real media files
patch by Moritz Bunkus <moritz@…>

comment:10 Changed 14 years ago by gamester17@…

Thanks. Hope the 4CC codes ("raac"/"racp") already been or will added too =)))
PS! Note that this was opened as a feature request, (not as a bug report) ;-)

comment:11 Changed 14 years ago by reimar

(In reply to comment #9)

Thanks. Hope the 4CC codes ("raac"/"racp") already been or will added too =)))

Why? I works without that for me, as they are used only in .rm files and are
converted to 'MP4A', which is the one everybody else uses. No idea why real
always thinks it has to do things different.
Or are there any files that need it?

PS! Note that this was opened as a feature request, (not as a bug report) ;-)

Which created additional confusion because that feature was already there
(especially as I had assumed that you had tried at least the latest release to
see if that feature is already there). You better should have mentioned your
MPlayer version.

Note: See TracTickets for help on using tickets.