Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1950 closed defect (fixed)

vo_directx crashes when minimized

Reported by: patrickdinh33@… Owned by: reimar
Priority: normal Component: vo
Version: HEAD Severity: normal
Keywords: Cc: pnixte@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

While using vo_directx for video output, minimizing the player window at any time results in a crash. Apparently, it's a regression introduced from r33657.

I have tested the latest svn revision on WinXP and Win7, and the crashing is still present.

However, it looks like a small bit of code from a prior revision is all that's needed to fix this. I've attached a patch for reference.

Attachments (1)

vo_directx_minimize_fix.patch (423 bytes) - added by patrickdinh33@… 9 years ago.
patch to fix vo_directx minimize crash

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by patrickdinh33@…

patch to fix vo_directx minimize crash

comment:1 Changed 9 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the report.
I restored the hunk exactly as it was in r33894.
Your variant isn't really correct, it will continue to show the video when colorkey is not used or supported even though the window is minimized.

comment:2 Changed 9 years ago by patrickdinh33@…

  • Cc pnixte@… added
Note: See TracTickets for help on using tickets.