Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1960 closed defect (fixed)

ASS/SSA timing breaks after seeking

Reported by: subjunk@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Using any value for -ss breaks ASS/SSA timing completely.

It's hard for me to be more specific because it doesn't seem to be consistent - other than being consistently very wrong.
At first it seemed that the subtitles started at 2x the value of -ss (e.g. if you use -ss 10 the subtitles will start at 20 seconds into the video) but it doesn't seem to consistently do that.

If you want a test video let me know. I tried it with 5 different videos and it happened with all of them.

Tested with r33961, r33953, r33936 and r33925 with the same results each time.

Change History (7)

comment:1 Changed 8 years ago by compn

  • Cc patriotact@… added

yes, a sample would be useful.

are you using -demuxer mkv or -demuxer lavf ?

comment:2 Changed 8 years ago by compn

is this a duplicate report of bug 1933 ?

comment:3 Changed 8 years ago by subjunk@…

It happens with literally any file with ASS/SSA subtitles, here is a file to sample: http://www.nyaa.eu/?page=torrentinfo&tid=90384
Let me know if you want a direct download link instead and I'll host one.

With regards to demuxer, it makes no difference to this bug. I just tested with both values and the bug occurs with both.

With regards to #1933, it's similar but since r33920 the fixpts bit is no longer needed for ASS/SSA subtitles (simply using -ass works now) so that bug is outdated. I have just closed it so we can use this one instead, which will hopefully avoid confusion.
I do suspect the same thing that is causing this bug was causing that bug, though.

comment:4 Changed 8 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Subtitle timing was based on the time stamps of the output file.
Please test r33998, I suspect it will have some other issues now...

comment:5 Changed 8 years ago by reimar

Make that r33999 instead.

comment:6 Changed 8 years ago by subjunk@…

Tested r34002 and it seems to have fixed this bug, thanks a lot!
What other issues do you anticipate?

comment:7 Changed 8 years ago by reimar

Nothing specific, but for this code I sure do anticipate issues out of principle/experience.

Note: See TracTickets for help on using tickets.