Opened 8 years ago

Closed 8 years ago

#1978 closed defect (worksforme)

Add application/ogg and audio/ogg as MIME types for Vorbis streams

Reported by: bugs@… Owned by: reimar
Priority: normal Component: streaming
Version: unspecified Severity: trivial
Keywords: Cc: compn
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Currently stream/network.c only recognizes "application/x-ogg" as a valid MIME type for Vorbis streams.

It should also include "application/ogg" (as for RFC 3534 and www.vorbis.com/faq, currently the most used MIME type for Vorbis streams as it's the one used by Icecast) and "audio/ogg" (as for newer RFC 5334, used for example in Music Player Daemon)

Change History (4)

comment:1 Changed 8 years ago by compn

  • Cc patriotact@… added

is there a stream or file that does not play correctly due to this ?

comment:2 Changed 8 years ago by bugs@…

Yes, all those streams that send tag updates between songs. For example:

http://ice.sess.nu:8000/classic.ogg

When a song change arrives, the stream is reset in order to send the title change, but mplayer doesn't play the next substream, instead writing "Cache not filling!".

This only happens with the LAVF demuxer (i.e, with "application/ogg" or "audio/ogg" MIME types). When the internal mplayer OGG demuxer is in use (only with "application/x-ogg" streams), there's no such a problem and the next substream is correctly played on song changes.

Perhaps this should be actually addressed in the LAVF demuxer, but forcing the internal demuxer doesn't look like a bad solution.

comment:3 Changed 8 years ago by reimar

I am quite sure the lavf demuxer is long since fixed, and indeed that stream plays just fine across song switches.
While those other mime types should probably be added, they rather should be added to default to the lavf demuxer now I think.

comment:4 Changed 8 years ago by compn

  • Resolution set to worksforme
  • Status changed from new to closed

lavf (and all of ffmpeg) doesnt keep track of mime types. so since the sample works, lets just close this bug. i dont think we even need those mime types in our code either? i wonder when they were used? hmm.

if you have a sample stream that still shows a problem, please report and reopen bug!

Note: See TracTickets for help on using tickets.