Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2017 closed defect (duplicate)

Floating Point Exception with output format lavf

Reported by: spoon.vw@… Owned by: reimar
Priority: normal Component: mencoder
Version: 1.0rc4 Severity: critical
Keywords: Cc: compn, spoon.vw@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

The command I'm attempting to run is:
mencoder 30sec.m4v -oac faac -faacopts mpeg=4:object=2:raw:br=128 -ovc lavc -of lavf -o 30sec.vol.mp4

You can find a copy of that file at:
http://dl.dropbox.com/u/15572438/30sec.m4v

Running the command using a rc4 build from september works fine:
http://dl.dropbox.com/u/15572438/r34132.out.txt

Running the command using a rc4 build from october fails:
http://dl.dropbox.com/u/15572438/r34245.out.txt

If you look at the output you can see it drops out at:
[mp4 @ 0xd45220]track 0: could not find tag, codec not currently supported in container
Floating point exception

Change History (8)

comment:1 Changed 8 years ago by spoon.vw@…

  • Cc spoon.vw@… added

comment:2 Changed 8 years ago by compn

  • Cc patriotact@… added

you may have to provide mencoder with -afmttag that corresponds with mp4 aac. 0xff maybe?

comment:3 Changed 8 years ago by spoon.vw@…

Tried it with your suggestion compn and same crash.

comment:4 Changed 8 years ago by compn

could you try with svn mencoder ?

MPlayer SVN-r34245 (C) 2000-2010 MPlayer Team

is pretty confusing since r34245 is october 23 2011.

i'm guessing you are doing something very wrong.

comment:5 Changed 8 years ago by spoon.vw@…

I was using the debian-multimedia builds (hence the build/date) when I saw this bug, and I contacted them. They tested and said it was a bug in the mencoder code and I'd need to create a bug report. I'm in the process of building mencoder from the SVN on a VM to see what kind of results I can get in a controlled environment.

(In reply to comment #3)

could you try with svn mencoder ?

MPlayer SVN-r34245 (C) 2000-2010 MPlayer Team

is pretty confusing since r34245 is october 23 2011.

i'm guessing you are doing something very wrong.

comment:6 Changed 8 years ago by compn

works with r34118 for me. i havent built mencoder in a while.

but we need gdb report if it crashes anyways :)

comment:7 Changed 8 years ago by spoon.vw@…

  • Resolution set to invalid
  • Status changed from new to closed

Works with the current SVN. I couldn't tell you what the problem I was having before, but I can't duplicate it now.

Thanks.

comment:8 Changed 8 years ago by reimar

  • Resolution changed from invalid to duplicate

The real issue should have been

track 0: could not find tag, codec not currently supported in

container

That should have been fixed by the fix for bug #2025 in r34378

Note: See TracTickets for help on using tickets.