Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2019 closed defect (fixed)

mplayer does not sound as good as VLC

Reported by: jidanni@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc: cehoyos
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Gentlemen, I have discovered mplayer does not sound as good as VLC,

$ clive http://www.youtube.com/watch?v=kyovCNUDvpU
$ ls -og *.flv
-rw-r--r-- 1 5188366 11-28 09:00 GotToGetClubVersionmp4.flv
$ mplayer *.flv #sounds like my headphones are damaged at each crash of

the drums about once a second throughout the song. One
gets a burst of static at each beat. Yuck.

$ vlc *.flv #ah, perfecto!

Debian version 2:1.0~rc4.dfsg1+svn33713-5

Attachments (1)

mp (1.3 KB) - added by jidanni@… 8 years ago.
mplayer output minus the progress counter stuff

Download all attachments as: .zip

Change History (10)

comment:1 Changed 8 years ago by cehoyos

  • Cc cehoyos@… added

Please provide the sample and please add complete, uncut MPlayer console output.

Changed 8 years ago by jidanni@…

mplayer output minus the progress counter stuff

comment:2 Changed 8 years ago by jidanni@…

The problem is very clear around 0:45. I tried it on two computers.
Please download the .flv file via clive(1) as above. It would take hours for
me to upload via ADSL.

comment:3 Changed 8 years ago by cehoyos

Unfortunately, I don't have clive on my computer, and if I download the file with other tools, the filesize is different, so please upload the sample as explained on http://ffmpeg.org/bugreports.html or provide it somewhere else.

comment:4 Changed 8 years ago by jidanni@…

http://gdata.youtube.com/feeds/api/videos/kyovCNUDvpU?prettyprint=true
makes one think that there is only one format. However, clive if given
--format=best gets a .webm file that sounds fine,
-rw-r--r-- 1 6017537 11-28 23:15 /var/tmp/GotToGetClubVersionmp4.webm
which is probably what you are getting. So all you need to do is select
"don't always download the best quality" in your downloader, thus
enabling you to download
-rw-r--r-- 1 5188366 11-28 21:57 /var/tmp/GotToGetClubVersionmp4.flv
which is the version that triggers the mplayer bug. Clive gets this version by default. Thanks.

comment:5 Changed 8 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

There are 4 different versions available, I doubt anyone cares to try to figure out which one clive happens to choose.
Anyway your MPlayer version is outdated and the issue is almost certainly fixed since r33824.
-softvol and reducing the volume should probably be a work-around.

comment:6 Changed 8 years ago by jidanni@…

(In reply to comment #5)

There are 4 different versions available,

$ clive --format flv_240p http://www.youtube.com/watch?v=kyovCNUDvpU !! the default

Anyway your MPlayer version is outdated and the issue is almost certainly fixed
since r33824.

OK I filed http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=650339
to get them to update so I can test the new Debian version.

-softvol and reducing the volume should probably be a work-around.

Well in fact I just get the static even more obvious at reduced volume... at four vertical bars seen after hitting 99999 it is very obvious.

comment:7 Changed 8 years ago by reimar

I think I was too optimistic with -softvol.
But -af volume worked I think.
Something like this at least, some filter meddling so that float values arrive at the volume filter, which will clamp them to the proper/allowed range.

comment:8 Changed 8 years ago by jidanni@…

Well guessing from the man page, all
-af volume=10.1:0
-af volume=0.1:0
-af volume=20.1:0 #horrid
-af volume=-20.1:0
no help. Anyway, it should get this right right out of the box. Not needing the user to use any options. (Note I am still using the same old versions that are as new as Debian gets. However I prefer to use .debs and not install it by hand.)

comment:9 Changed 8 years ago by jidanni@…

  • Resolution changed from invalid to fixed

Indeed, the song sounds fine now in
Version table:

* 2:1.0~rc4.dfsg1+svn34540-1+b1 0

500 http://ftp.tw.debian.org/debian/ unstable/main i386 Packages

Note: See TracTickets for help on using tickets.