Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2025 closed defect (fixed)

lavf no longer appears to detect source codec to determine that it will be suited for the desired output container

Reported by: thrulet@… Owned by: reimar
Priority: normal Component: mencoder
Version: unspecified Severity: normal
Keywords: Cc: spoon.vw@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When I use the MEncoder executable SVN-r34185, my encoding command returns the following information for a routine conversion:
"VIDEO CODEC ID: 28
AUDIO CODEC ID: 15002, TAG: 0"

More recent versions including today's SVN-r34375 shows this instead:

"VIDEO CODEC ID: 0
AUDIO CODEC ID: 0, TAG: 0"

Then the following line appears just before encoding fails:

"[mp4 @ 0x10c41d180]track 0: could not find tag, codec not currently supported in container"
The problem is not reproducible with MPlayer. MEncoder produces an empty file. Here's a sample of a typical source video.

http://dl.dropbox.com/u/42718751/friendoranemone.mp4

Here's the command.


mencoder friendoranemone.mp4 -o friendoranemone.iPad.mp4 -vf filmdint=io=30:24/fast=0/sad_thres=2048,softskip,gradfun,fspp,scale=1280:720,harddup -of lavf -lavfopts format=ipod -alang en -oac faac -faacopts br=192:mpeg=4:object=2:raw -fps 30000/1001 -ofps 24000/1001 -mc 0.1 -ovc x264 -x264encopts crf=28:bitrate=1300:nocabac:level_idc=31:bframes=0:global_header:threads=auto:subq=5:frameref=1:partitions=all:trellis=1:chroma_me:qcomp=0.7:qp_step=4:me=umh:weightp=0:8x8dct=0:direct_pred=auto


Here's the output.


MEncoder SVN-r34375-4.2.1 (C) 2000-2011 MPlayer Team
get_path('codecs.conf') -> '/Users/llee/.mplayer/codecs.conf'
Reading optional codecs config file /Users/llee/.mplayer/codecs.conf: No such file or directory
Reading optional codecs config file /usr/local/etc/mplayer/codecs.conf: No such file or directory
Using built-in default codecs.conf.
init_freetype
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay?
get_path('fonts') -> '/Users/llee/.mplayer/fonts'
Configuration: --cc=gcc-4.2 --disable-live
[file] File size is 944307571 bytes
STREAM: [file] /Users/llee/Documents/Roxio Converted Items/JacobsLadder?.mp4
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
success: format: 0 data: 0x0 - 0x3848fd73
LAVF_check: QuickTime?/MPEG-4/Motion JPEG 2000 format
libavformat file format detected.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x1039c5380]ISO: File Type Major Brand: mp42
[h264 @ 0x1039cdd80]err{or,}_recognition separate: 1; 1
[h264 @ 0x1039cdd80]err{or,}_recognition combined: 1; 65537
[aac @ 0x1039cdd80]err{or,}_recognition separate: 1; 1
[aac @ 0x1039cdd80]err{or,}_recognition combined: 1; 65537
[aac @ 0x1039cdd80]Unsupported bit depth: 0
[h264 @ 0x1039cdd80]Frame num gap 16 11
[h264 @ 0x1039cdd80]Frame num gap 16 12
[h264 @ 0x1039cdd80]Frame num gap 16 13
[h264 @ 0x1039cdd80]Frame num gap 16 14
[h264 @ 0x1039cdd80]Increasing reorder buffer to 1
[h264 @ 0x1039cdd80]no picture
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x1039c5380]All info found
==> Found video stream: 0
======= VIDEO Format ======

biSize 105
biWidth 720
biHeight 480
biPlanes 0
biBitCount 24
biCompression 875967048='H264'
biSizeImage 1036800

Unknown extra header dump: [1] [4d] [40] [1f] [ff] [e1] [0] [32] [67] [4d] [40] [1f] [9a] [62] [81] [68] [7b] [7f] [e0] [1] [0] [1] [3e] [a0] [20] [20] [28] [0] [0] [1f] [48] [0] [e] [a6] [7] [46] [0] [2] [62] [58] [0] [17] [d7] [97] [79] [c1] [a3] [0] [1] [31] [2c] [0] [b] [eb] [cb] [bc] [e0] [50] [1] [0] [4] [68] [ee] [3c] [80]
===========================
[lavf] stream 0: video (h264), -vid 0
==> Found audio stream: 1
======= WAVE Format =======
Format Tag: 20557 (0x504D)
Channels: 2
Samplerate: 48000
avg byte/sec: 15999
Block align: 1
bits/sample: 16
cbSize: 2
Unknown extra header dump: [11] [90]
==========================================================================
[lavf] stream 1: audio (aac), -aid 0, -alang eng
LAVF: 1 audio and 1 video streams found
LAVF: build 3479552
VIDEO: [H264] 720x480 24bpp 59.940 fps 983.3 kbps (120.0 kbyte/s)
[V] filefmt:35 fourcc:0x34363248 size:720x480 fps:59.940 ftime:=0.0167
Input fps will be interpreted as 59.940 instead.
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
dec_audio: Allocating 192000 + 131072 = 323072 bytes for output buffer.
FFmpeg's libavcodec audio codec
[aac @ 0x1039cdd80]err{or,}_recognition separate: 1; 1
[aac @ 0x1039cdd80]err{or,}_recognition combined: 1; 65537
[aac @ 0x1039cdd80]Unsupported bit depth: 0
INFO: libavcodec "aac" init OK!
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 15999->192000)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
[file] File size is 0 bytes
STREAM: [file] /Users/llee/Documents/Roxio Converted Items/JacobsLadder?.ipad.mp4
STREAM: Description: File
STREAM: Author: Albeu
STREAM: Comment: based on the code from ??? (probably Arpi)
MUXER_LAVF *
REMEMBER: MEncoder's libavformat muxing is presently broken and can generate
INCORRECT files in the presence of B-frames. Moreover, due to bugs MPlayer
will play these INCORRECT files as if nothing were wrong!
*
OK, exit.
ALLOCATED STREAM N. 1, type=0
Opening video filter: [expand osd=1]
Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
Opening video filter: [framestep=2]
Opening video filter: [softskip]
Opening video filter: [filmdint=io=30:24]
Opening video filter: [scale w=720 h=400]
SwScale? params: 720 x 400 (-1=no scaling)
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[h264 @ 0x1039cdd80]err{or,}_recognition separate: 2; 1
[h264 @ 0x1039cdd80]err{or,}_recognition combined: 2; 196609
INFO: libavcodec init OK!
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
ALLOCATED STREAM N. 2, type=1
Building audio filter chain for 48000Hz/2ch/s16le -> 0Hz/0ch/??...
[libaf] Adding filter dummy
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
AE_FAAC, sample_input: 2048, max_bytes_output: 1536
Building audio filter chain for 48000Hz/2ch/s16le -> 48000Hz/2ch/s16le...
[dummy] Was reinitialized: 48000Hz/2ch/s16le
[dummy] Was reinitialized: 48000Hz/2ch/s16le
Increasing filtered audio buffer size from 0 to 6144
Unsupported PixelFormat? 61
Unsupported PixelFormat? 53
Unsupported PixelFormat? 81
[h264 @ 0x1039cdd80]Frame num gap 16 11
[h264 @ 0x1039cdd80]Frame num gap 16 12
[h264 @ 0x1039cdd80]Frame num gap 16 13
[h264 @ 0x1039cdd80]Frame num gap 16 14
[ffmpeg] aspect_ratio: 1.333333
VDec: vo config request - 720 x 480 (preferred colorspace: Planar YV12)
Trying filter chain: scale filmdint softskip framestep expand x264
VDec: using Planar I420 as output csp (no 1)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO Config (720x480->854x480,flags=0,'MPlayer',0x30323449)
SwScaler?: reducing / aligning filtersize 1 -> 4
SwScaler?: reducing / aligning filtersize 1 -> 4
SwScaler?: reducing / aligning filtersize 6 -> 6
SwScaler?: reducing / aligning filtersize 6 -> 6
[swscaler @ 0x1039c1060]BICUBIC scaler, from yuv420p to yuv420p using MMX2
[swscaler @ 0x1039c1060]720x480 -> 720x400
[swscaler @ 0x1039c1060]lum srcW=720 srcH=480 dstW=720 dstH=400 xInc=65536 yInc=78643
[swscaler @ 0x1039c1060]chr srcW=360 srcH=240 dstW=360 dstH=200 xInc=65536 yInc=78643
REQ: flags=0x403 req=0x0
REQ: flags=0x403 req=0x400
REQ: flags=0x403 req=0x0
REQ: flags=0x403 req=0x400
REQ: flags=0x3 req=0x0
x264 [info]: using SAR=100/101
x264 [info]: using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle? SSE4.2 AVX
x264 [info]: profile High, level 3.1
* [scale] Exporting mp_image_t, 720x480x12bpp YUV planar, 518400 bytes
* [filmdint] Direct Rendering mp_image_t, 720x400x12bpp YUV planar, 432000 bytes
[swscaler @ 0x1039c1060]Warning: dstStride is not aligned!

->cannot do aligned memory accesses anymore

[swscaler @ 0x1039c1060]Warning: data is not aligned! This can lead to a speedloss
* [softskip] Exporting mp_image_t, 720x400x12bpp YUV planar, 432000 bytes
* [framestep] Exporting mp_image_t, 720x400x12bpp YUV planar, 432000 bytes
* [expand] Exporting mp_image_t, 720x400x12bpp YUV planar, 432000 bytes
* [x264] Allocating mp_image_t, 720x400x12bpp YUV planar, 432000 bytes
Unicode font: 255 glyphs.
Unicode font: 255 glyphs.
Pos: 0.0s 1f ( 0%) 0fps Trem: 0min 0mb A-V:0.000 [0:0] A/Vms 1/393 D/B/S 0/0/0
[h264 @ 0x1039cdd80]Increasing reorder buffer to 1
[h264 @ 0x1039cdd80]no picture
Pos: 0.1s 8f ( 0%) 0fps Trem: 0min 0mb A-V:0.000 [0:0] A/Vms 1/88 D/B/S 0/5/0
* [softskip] Allocating mp_image_t, 720x400x12bpp YUV planar, 432000 bytes
Pos: 2.2s 131f ( 0%) 101fps Trem: 0min 0mb A-V:0.000 [0:193] A/Vms 1/8 D/B/S 0/79/0
Muxer frame buffer sending 127 frame(s) to the muxer.
VIDEO CODEC ID: 0
AUDIO CODEC ID: 0, TAG: 0
MUXER_LAVF(audio stream) frame_size: 1024, scale: 1024, sps: 48000, rate: 48000, ctx->block_align = stream->wf->nBlockAlign; 0=1024 stream->wf->nAvgBytesPerSec:24221
Writing header...
[mp4 @ 0x1039c5380]Codec for stream 0 does not use global headers but container format requires global headers
[mp4 @ 0x1039c5380]Codec for stream 1 does not use global headers but container format requires global headers
[mp4 @ 0x1039c5380]track 0: could not find tag, codec not currently supported in container
/tmp/execme.command: line 9: 97851 Floating point exception: 8 /usr/local/bin/mencoder -v '/Users/llee/Documents/Roxio Converted Items/JacobsLadder?.mp4' -oac copy -o '/Users/llee/Documents/Roxio Converted Items/JacobsLadder?.ipad.mp4' -demuxer lavf -vf scale=720:400,filmdint=io=30:24,softskip,framestep=2 -noskip -mc 0 -of lavf -lavfopts format=mp4 -aspect 16/9 -alang en -oac faac -faacopts br=192:mpeg=4:object=2:raw -ovc x264 -x264encopts crf=28:bitrate=1375:nocabac:level_idc=31:bframes=0:global_header:qcomp=0.7:threads=auto:subq=5:frameref=1:partitions=all:trellis=1:qp_step=4 -fps 60000/1001 -ofps 24000/1001


I'm hoping that the previous functionality can be restored.

http://thread.gmane.org/gmane.comp.video.mencoder.user/12707/focus=12718

Thanks.

Laine Lee

Change History (3)

comment:1 Changed 8 years ago by thrulet@…

  • Component changed from demuxer to mencoder

I should have selected mencoder for the component, I think, sorry.

Anyway, I was really hopeful that todays svn, which included upgrades to libmpdemux/mp_taglists.c and etc/codecs.conf, might fix it, but it didn't. Thanks.

  1. Lee

comment:2 Changed 8 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in SVN r34378.
Was broken by the compilation fix in r34243.

comment:3 Changed 8 years ago by reimar

  • Cc spoon.vw@… added
Note: See TracTickets for help on using tickets.