Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2029 closed defect (invalid)

Build from latest git/svn fails with PIX_FMT_0RGB32' undeclared here

Reported by: grgoffe@… Owned by: diego@…
Priority: important Component: build system
Version: HEAD Severity: major
Keywords: Cc: cehoyos
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hi,

System is up to date FC16-x86_64.

Mplayer started failing a few days ago. Am I doing something wrong?

Thanks,

George...

cc -MD -MP -Wundef -Wall -Wno-switch -Wno-parentheses -Wpointer-arith -Wredundant-decls -Wstrict-prototypes -Wmissing-prototypes -Wdisabled-optimization -Wno-pointer-sign -Wdeclaration-after-statement -std=gnu99 -Werror-implicit-function-declaration -O4 -march=native -mtune=native -pipe -ffast-math -fomit-frame-pointer -fno-tree-vectorize -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -Ilibdvdread4 -I. -Iffmpeg -D_REENTRANT -pthread -I/usr/include/kde/artsc -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/freetype2 -pthread -I/usr/include/gtk-2.0 -I/usr/lib64/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -c -o fmt-conversion.o fmt-conversion.c
fmt-conversion.c:60:22: error: 'PIX_FMT_0RGB32' undeclared here (not in a function)

Change History (5)

comment:1 Changed 8 years ago by cehoyos

  • Cc cehoyos@… added

Please confirm that you did:
$ make distclean
$ svn up
$ ./configure && make

If you are using a self-provided version of FFmpeg, you are on your own;-(

comment:2 Changed 8 years ago by diego@…

  • Resolution set to invalid
  • Status changed from new to closed

Unreproducible on x86_64.

comment:3 Changed 8 years ago by grgoffe@…

Carl,

Thank you for your response.

My ffmpeg was retrieved from your download site as I recall. I set this mplayer build environment up some time ago.

I don't do a distclean since I rebuild an object directory each time I build. You can see this in the script snippet below.

I can provide you a COMPLETE build log if that will help.

Regards and THANKS for your help,

George...

77
78 cd mplayer/ffmpeg
79 git pull
80 rc=$?
81
82 if $rc ?
83 then
84 :
85 else
86 echo 'No apparent updates... is this right?'
87 exit $rc
88 fi
89
90 cd ..
91
92 svn up
93 rc=$?
94
95 if $rc ?
96 then
97 :
98 else
99 echo 'No apparent updates... is this right?'

100 exit $rc
101 fi
102
103 cd ..
104
105 rm -fr obj-i686-pc-linux-gnu
106
107 mkdir obj-i686-pc-linux-gnu
108
109 cd obj-i686-pc-linux-gnu
110
111 lndir ../mplayer
112
113 ./configure --prefix=/usr/lsd/$osnamee \
114 --enable-gui \
115 --enable-menu
116

comment:4 Changed 8 years ago by grgoffe@…

Diego,

Did you try this on a Fedora Core 16 system by any chance?

Regards,

George...

comment:5 Changed 8 years ago by grgoffe@…

Diego, et. al.,

Apparently some sort of problem with ffmpeg(git) AND the mplayer(svn) trees existed in my copies. I resolved these 2 problems and re-executed git pull and svn update and the copies came clean... at which point, the build succeeded.

If anyone is interested I have a record of most of what I did to resolve the problem. It was rather easy since I'm not making code changes.

Regards,

George...

Note: See TracTickets for help on using tickets.