Opened 8 years ago

Last modified 8 years ago

#2036 closed defect (fixed)

mplayer + libass CR/LF problem

Reported by: lorefice2@… Owned by: eugeni.stepanov@…
Priority: normal Component: libass
Version: unspecified Severity: normal
Keywords: Cc: cehoyos, mplayer.bug.gillux@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

  1. install libass 0.10.x
  2. Play the attached file: mplayer sample.mkv -ass -slang eng
  1. See that after every line there is an empty "box"
  1. install libass 0.9.13 and play the same way
  2. see that there isnt any box

I tried mplayer, mplayer2 and mplayer-vaapi from archlinux package and they all performs the same.
My system is linux 32bit 3.0.4

Note that this issue has been already reported to libass guys, here:
http://code.google.com/p/libass/issues/detail?id=44#makechanges

And it seems that (from an user):
"only SRT subbtitles are affected. SSA/ASS are not."

And also (from a developer):
"This is a bug in MPlayer's text subtitle converter, which doesn't strip off \r at the end of a CRLF line ending. Unknown codepoints are now handled differently. Previously, nothing was rendered for those, but now the replacement character is rendered, as recommended in the OpenType? specification. So that \r is now displayed, but it's not a problem in libass.

Change History (4)

comment:1 Changed 8 years ago by lorefice2@…

Attachment add failed, here is the sample:
http://wpage.unina.it/aorefice/sharevari/sample.mkv

comment:2 Changed 8 years ago by kristian.laakkonen@…

It seems the bug is already fixed in mplayer2, but not in mplayer: http://git.mplayer2.org/mplayer2/commit/?id=3e0a2705595cbf991e0428984052488ad94c6d21

comment:3 Changed 8 years ago by mplayer.bug.gillux@…

  • Cc mplayer.bug.gillux@… added

I tested the mplayer2 patch pointed out by Kristian on mplayer r34833. It solved the problem. It’s a trivial patch, could you please commit it?

comment:4 Changed 8 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed, cehoyos@ag.or.at

Fixed by Clément Bœsch.

Note: See TracTickets for help on using tickets.