Opened 6 years ago

Closed 5 years ago

#2041 closed defect (fixed)

r34383 causes Hebrew subtitles to be reversed

Reported by: subjunk@… Owned by: reimar
Priority: normal Component: core
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Before r34383, Hebrew subtitles displayed in the correct order (right-to-left), but that revision (which updated libass) caused them to incorrectly display left-to-right.

Change History (5)

comment:1 Changed 6 years ago by reimar

Some additional information, please say if this does not match your experience.
1) This only happens with external subtitles.
2) This only happens with -ass
3) This can be worked around by adding (counterintuitively) -noflip-hebrew whenever using -ass

comment:2 Changed 6 years ago by subjunk@…

Thanks for the comment, Reimar, I'll test it ASAP and get back to you

comment:3 Changed 6 years ago by subjunk@…

Sorry for the delay, yes I can confirm those 3 points are correct.

comment:4 Changed 5 years ago by subjunk@…

Any update on this?

comment:5 Changed 5 years ago by subjunk@…

  • Resolution set to fixed
  • Status changed from new to closed

I think this bug is fixed now, since the libass update to 0.10.1

Note: See TracTickets for help on using tickets.