Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#207 closed defect (invalid)

stuttering sound with -ac hwac3

Reported by: stranche@… Owned by: alex@…
Priority: normal Component: ao
Version: 1.0pre6 Severity: blocker
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

On Fedora Core 3 and Mplayer 1.0pre6

When playing a file with an AC3 sound track using "mplayer -ao alsa -ac hwac3"
the sound is very distorded like a scratched or dirty audio CD.

It played fine until MPlayer 1.0pre4 on Fedora Core 2

I dunno if it's Alsa, liba52 or MPlayer related, very annoying anyway.

Change History (8)

comment:1 Changed 14 years ago by reimar

(In reply to comment #0)

I dunno if it's Alsa, liba52 or MPlayer related, very annoying anyway.

liba52 is not involved when playing with hwac3. But I think -ao alsa didn't yet
exist in pre4?? Can you try pre5 and CVS?

comment:2 Changed 14 years ago by stranche@…

In pre4 the ALSA subsystem was called with -ao alsa9.
The same problem happened in pre5, I hopped that the pre6 could fix it but
wasn't the case.
Just tryed the CVS, no progress.

liba52 is not involved when playing with hwac3. But I think -ao alsa didn't yet
exist in pre4?? Can you try pre5 and CVS?

comment:3 Changed 14 years ago by reimar

Forgot to say, please list a full -v log for both a working and a non-working
version, otherwise I can't help, I don't have any hardware to test this on.
Are you maybe using -channels? If yes, try without.

comment:4 Changed 14 years ago by stranche@…

to complete my precedent post
with actual CVS the player just gives me this:

Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/8bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, big-endian AC3
AF_pre: 48000Hz 2ch big-endian AC3
alsa-init: 1 soundcard found, using: iec958:AES0:0x2,AES1:0x82,AES2:0x0,AES3:0x2
ALSA lib conf.c:3818:(parse_args) Parameter DEV must be an integer
ALSA lib conf.c:3912:(snd_config_expand) Parse arguments error: Argument invalide
ALSA lib pcm.c:1972:(snd_pcm_open_noupdate) Unknown PCM
iec958:AES0:0x2,AES1:0x82,AES2:0x0,AES3:0x2
alsa-init: playback open error: Argument invalide
Could not open/initialize audio device -> no sound.
Audio: no sound

(In reply to comment #2)

In pre4 the ALSA subsystem was called with -ao alsa9.
The same problem happened in pre5, I hopped that the pre6 could fix it but
wasn't the case.
Just tryed the CVS, no progress.

liba52 is not involved when playing with hwac3. But I think -ao alsa didn't yet
exist in pre4?? Can you try pre5 and CVS?

comment:5 Changed 14 years ago by stranche@…

Damnit !!
Now I will look stupid here...

I just tryed some configs just to get outputs and saw that the feature is
resolved...

I have an idea on what happened : as I'm on Fedora Core 3, I just upgraded the
kernel to kernel-2.6.10-1.741_FC3 something like 2 days ago.
The problem was still kicking last week, so my guess is that ALSA modules were
at fault here and this kernel upgrade (sync with 2.6.10-ac9) fixed the whole
thing (you can find lots of ALSA CVS update in it).

I guess I'm not the only one with this problem, if anyone could confirm to issue
an information ?
For me now the problem is resolved, should I leave open for the moment to allow
people to add comments ?

comment:6 Changed 14 years ago by reimar

  • Resolution set to invalid
  • Status changed from new to closed

(In reply to comment #5)

The problem was still kicking last week, so my guess is that ALSA modules were
at fault here and this kernel upgrade (sync with 2.6.10-ac9) fixed the whole
thing (you can find lots of ALSA CVS update in it).

Maybe also look at
http://sourceforge.net/mailarchive/message.php?msg_id=10552053 , it fixes a
memleak when changing volume ;-)

For me now the problem is resolved, should I leave open for the moment to allow
people to add comments ?

comments can still be added after closing/resolving. As it seems not to be an
MPlayer bug resolving as invalid, feel free to reopen again if necessary.

comment:7 Changed 14 years ago by reimar

(In reply to comment #4)

to complete my precedent post
with actual CVS the player just gives me this:

Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/8bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, big-endian AC3
AF_pre: 48000Hz 2ch big-endian AC3
alsa-init: 1 soundcard found, using: iec958:AES0:0x2,AES1:0x82,AES2:0x0,AES3:0x2
ALSA lib conf.c:3818:(parse_args) Parameter DEV must be an integer
ALSA lib conf.c:3912:(snd_config_expand) Parse arguments error: Argument invalide
ALSA lib pcm.c:1972:(snd_pcm_open_noupdate) Unknown PCM
iec958:AES0:0x2,AES1:0x82,AES2:0x0,AES3:0x2

Forgot to reply to this: current CVS tries S/PDIF output for hwac3 by default,
as described in the manpage. But this also means that everyone who wants to use
"real" hwac3 decoding must use e.g. -ao alsa:device=default
Please tell me if this actually works.

comment:8 Changed 14 years ago by stranche@…

Being tested (and resolved ?) at the bug #197 report
http://bugzilla.mplayerhq.hu/show_bug.cgi?id=197

Note: See TracTickets for help on using tickets.