Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#209 closed defect (fixed)

end of stream not detected when playing pnm://real.audio.ra

Reported by: ttomjones@… Owned by: r_togni@…
Priority: normal Component: demuxer
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Maybe there is a more serious error in the pnm library - you may also refer to
pnm://ra.gospelcom.net/ab/audio/kjv/1Chronicles_01.ra (I found that url while
searching for anthoer server to check if the error I report is bound to "my"
specific server) which nearly completely fails to play.

I hope I correctly assigned that problem to the demuxer, if not: sorry

+++OT+++
If you understand german and liked the Wischmeyer stream, it's usually send on
a weekly basis - so you might enjoy in/decreasing the date by 7 days.

Change History (7)

comment:1 Changed 14 years ago by reimar

This maybe is not a pnm stream, at least I get only connection refused. Why http
fallback doesn't work correctly is a different question...
At least the same URL with http:// works fine for me.
Btw. pnm is known to be not working correctly so if somebody has some time...

comment:2 Changed 14 years ago by ttomjones@…

At least the same URL with http:// works fine for me.

True, concerning the gospelcom URL.
But unfortunally the HTTP fallback *is* deactivated for some reason.

And I'm intrested in saving the Wischmeyer streams. So I'm hoping that somebody
has a clue how to fix the problem...

comment:3 Changed 14 years ago by ttomjones@…

This maybe is not a pnm stream, at least I get only connection refused.

Sorry I forgot to answer that.
I cannot explain that - using mplayer and Media Player Classic I can play that
stream in general.

Maybe it can only be streamed localised?
Would it help to publish the output from 'mplayer -dumpstream URL'?

comment:4 Changed 14 years ago by r_togni@…

  • Owner changed from moritz@… to r_togni@…

The gospel url has a known problem with pnm, related to authentication: mplayer
pnm authentication is very tricky, it sends some "fake" data that is usually
accepted by servers (this includes a fake timestamp, maybe that's the problem).
But some resvers are more picky (or just newer), and reject it with the "your
player is too old..." message. I have no idea how to fix it, and it will
probably stay unfixed unless someone wast to reverese (again) that old protocol
and fix it. Btw the new realplayer from helix (yes, the binary-only one) does
not support pnm anymore.
To make it work just replace pnm:// with rtsp://, this always worked for me for
servers that refused pnm authentication. This in not how realplayer behaves, but
i'm thinking abut adding fallback to realrtsp if pnm fails with "too old" message.
Since i don't get a connection refused, i can't test for the fallback to http
(it's there only if connection is refused, not if protocol fails).

The Wishmeyer stream works, but eof not detected as you reported. This is a bug,
i'll look at it (but don't expect a quick solution).

The stream can be dumped ok with -dumpstream, just hit CTRL-C when it's done.

comment:5 Changed 14 years ago by ttomjones@…

(In reply to comment #4)

The gospel url [...]

That URL was just an example. But thanks for that hint.

The Wishmeyer stream works, but eof not detected as you reported. This is a

bug,

i'll look at it (but don't expect a quick solution).

I don't. But I'd appreciate a short notice when it has been fixed.

The stream can be dumped ok with -dumpstream, just hit CTRL-C when it's done.

Yes I got that. But it isn't really helpful when intenting to save *all* the
possible Wischmeyer streams using a script - especially when you do not hear
the end -> at least using mplayer under Windows I don't hear something while -
dumpstream.
But that may be by design.

comment:6 Changed 14 years ago by r_togni@…

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed in CVs, please test.
Now MPlayer should stop on pnm eof and on unplayable pnm streams

comment:7 Changed 14 years ago by ttomjones@…

(In reply to comment #6)

Should be fixed in CVs, please test.
Now MPlayer should stop on pnm eof and on unplayable pnm streams

Thank you very much!

+++OT+++
Someone should apply this:

E:\mplayer\main>cvs diff mplayer.c
Index: mplayer.c
===================================================================
RCS file: /cvsroot/mplayer/main/mplayer.c,v
retrieving revision 1.838
diff -r1.838 mplayer.c
3285a3286

#ifdef HAVE_FREETYPE

3287a3289

#endif /* HAVE_FREETYPE */

Note: See TracTickets for help on using tickets.