Opened 7 years ago

Closed 7 years ago

#2092 closed defect (fixed)

fuzzed wmv file causes mplayer to hang

Reported by: hanno@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

With attached file, mplayer hangs forever. It's a sample of Sam Hocevar's zzuf tests.

Attachments (1)

lol-mplayer.wmv (64.0 KB) - added by hanno@… 7 years ago.
lol-mplayer.wmv

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by hanno@…

lol-mplayer.wmv

comment:1 Changed 7 years ago by reimar

I am fairly certain it does not hang at all, but just sleep for just below 150 hours.
Not that it makes much of a difference to a user.

comment:2 Changed 7 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

Behaviour should be more user-friendly from r35226.
It will still insist on displaying that frame for several hours if you don't stop it manually, but that is kind of "works as intended".

Note: See TracTickets for help on using tickets.