Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#2094 closed defect (fixed)

lavcac3enc doesn't work after SVN update (ac3_fixed sample_fmt is not supported)

Reported by: mgarski@… Owned by: reimar
Priority: normal Component: af
Version: HEAD Severity: major
Keywords: Cc: cehoyos
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

Hi

On 13 October 2012 I have compiled fresh MPlayer from SVN (r35245). Then I have tried to play one of my movies, that previously works flawlessly. But I get the error:
[ac3_fixed @ 0xeb9000]Specified sample_fmt is not supported.
Couldn't open codec ac3, br=640000.
[libaf] Reinitialization did not work, audio filter 'lavcac3enc' returned error code -2
Error at audio filter chain pre-init!

This movie worked on MPlayer compiled on 06 October, I didn't change anything in MPlayer's config, which is:
ao=alsa
channels=6
af=scaletempo,lavcac3enc=1:640:3
ac=hwac3,

Movie details:
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 54.65.100 (internal)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Forced audio codec: hwac3
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 6 ch, floatle, 1536.0 kbit/16.67% (ratio: 192000->1152000)
Selected audio codec: [ffdca] afm: ffmpeg (FFmpeg DTS)
==========================================================================

Attachments (2)

config (178 bytes) - added by mgarski@… 5 years ago.
MPlayer's config
output (1.5 KB) - added by mgarski@… 5 years ago.
MPlayer's output (mplayer movie.mkv)

Download all attachments as: .zip

Change History (18)

comment:1 Changed 5 years ago by cehoyos

  • Cc cehoyos@… added

af lavcac3enc works fine here with current svn head - could you try again and if it does not work, please provide your complete command line together with the complete, uncut console output?

Changed 5 years ago by mgarski@…

MPlayer's config

comment:2 Changed 5 years ago by mgarski@…

Changed 5 years ago by mgarski@…

MPlayer's output (mplayer movie.mkv)

comment:3 Changed 5 years ago by mgarski@…

comment:4 Changed 5 years ago by mgarski@…

(In reply to comment #1)
No problem (MPlayer SVN-r35279) and still MPlayer exits with fatal error. Config and full output attached. FYI it happens when I play a movie with 5.1 DTS that should be recoded to 5.1 AC-3.

comment:5 Changed 5 years ago by cehoyos

Sorry, I tested a mono file, only mono files still work.

This is a regression since FFmpeg commit 79d3032

comment:6 Changed 5 years ago by mgarski@…

As I see, after FFmpeg commit 79d3032 ac3 encoder use planar sample format (AV_SAMPLE_FMT_S16P), but lavcac3enc set it as AV_SAMPLE_FMT_S16.

Any chance to get it fixed?

comment:7 Changed 4 years ago by mgarski@…

Still valid for MPlayer SVN-r36294

comment:8 Changed 4 years ago by mgarski@…

Reimar please fix this bug. I am stick at using one year old MPlayer, because of this :(

comment:9 Changed 4 years ago by reimar

I was still hoping for someone else doing it.
But I'll try to find time for it. No promises on when though, maybe I manage this weekend.
Though I think I can't even properly test lavcac3enc.

comment:10 Changed 4 years ago by mgarski@…

Thanks that you will try to look at it. I've uploaded test sample at ftp://upload.mplayerhq.hu/MPlayer/incoming/bug_2094/dts_sfx.vob that gives this error. Hope it will help.

comment:11 Changed 4 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

It is very badly done, but it seems to work for me again with SVN r36431.

comment:12 Changed 4 years ago by mgarski@…

Thanks Reimar for fixing this, it also works for me!
The only problem I have observed is that something changed with channels order.
My rear right speaker is mostly silent, but left speaker not. On old release this was not an issue.

I see that you have removed reorder_channel_nch(), can you revert this without breaking sample format, or it has to be this way?

comment:13 Changed 4 years ago by reimar

I haven't removed it it's still there in the helper function.
I used the code from ae_lavc though, not the one that was in af_lavcac3enc.
No idea if it makes a difference.
You'll need to give more details, a sample, or debug yourself.

comment:14 Changed 4 years ago by mgarski@…

I have uploaded test file: ftp://upload.mplayerhq.hu/MPlayer/incoming/bug_2094_test/test.dts
It is a channels test file, with FFmpeg commit before 79d3032 you can hear the voice in proper speaker, but after MPlayer SVN r36431:

[Should be] -> [Is actually played]

Subwoofer -> Right rear
Left front -> Left front (GOOD!)
Left rear -> Center
Right rear -> Subwoofer
Right front -> Right front (GOOD!)
Center -> Left rear

You need some other details?

comment:15 Changed 4 years ago by reimar

Please try r36434.

comment:16 Changed 4 years ago by mgarski@…

Works like a charm. Big thanks!

Note: See TracTickets for help on using tickets.