Opened 6 years ago

Closed 6 years ago

#2098 closed defect (fixed)

DTS 7.1 decoding broken

Reported by: subjunk@… Owned by: reimar
Priority: normal Component: core
Version: HEAD Severity: normal
Keywords: Cc: cehoyos
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

This is another bug caused by the recent planar audio addition in libav.
FFmpeg does not have the bug though, so as with the AC-3 bug this does seem to be a bug with MPlayer's implementation of planar audio rather than a bug in libav.

Sample file: http://lipqpj.1fichier.com/ (click the button down the bottom "Telecharger le fichier" for instant download)

Command line:

mencoder dts71.m2ts -oac lavc -of mpeg -ovc lavc -o output.mpeg

What happens is that MEncoder just exits without doing anything or displaying an error code. Here is the complete output:

MEncoder (C) 2000-2012 MPlayer Team

success: format: 0 data: 0x0 - 0x5589000
libavformat version 54.29.105 (internal)
TS file format detected.
VIDEO VC1(pid=4113) AUDIO DTS(pid=4352) NO SUBS (yet)! PROGRAM N. 1
Searching for VC1 sequence header... found
VIDEO: VC-1 1920x1080, 23.976 fps, header len: 33
[V] filefmt:29 fourcc:0x31435657 size:1920x1080 fps:23.976 ftime:=0.0417
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
libavcodec version 54.63.100 (internal)

Change History (4)

comment:1 Changed 6 years ago by subjunk@…

By the way, the specific FFmpeg revision that caused this bug was e88ca80; 82db8ee works perfectly.

comment:2 Changed 6 years ago by cehoyos

  • Cc cehoyos@… added

This is FFmpeg ticket #1827, work-around is to add -channels 8 to the command line.

comment:3 Changed 6 years ago by subjunk@…

Ah ok, cool. Will be great to see this fixed since my main usage case needs -channels 2.

comment:4 Changed 6 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in current MPlayer.

Note: See TracTickets for help on using tickets.