Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#2101 closed defect (fixed)

Playback of WAV files truncated on Windows

Reported by: tom_bogle@… Owned by: reimar
Priority: normal Component: ao
Version: unspecified Severity: normal
Keywords: Cc: qweac01@…
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

On Windows (tested on Win7 and XP at least), playback of ordinary 16-bit WAV files always terminates early, cutting off the last half second or so of the recording. We figured out that you can work around this problem by specifying the -ao win32 switch, but it doesn't seem like this should be required. I'd be happy to supply a sample file if needed, but it seems like this problem happens for all WAV files (and possibly other types as well).

Change History (5)

comment:1 Changed 7 years ago by reimar

I just tested on a Windows 7 machine, using audio output via HDMI with a HD5700 graphics card.
I can't reproduce this issue, and there is code that removes the loop flag from the output buffer and then waits for the buffer state to be no longer "playing".
So I don't see MPlayer doing anything wrong, though I admit my test sample wasn't perfect so it's not impossible I missed something.

comment:2 Changed 6 years ago by reimar

If someone has an idea how to debug this or work around it, it is welcome.
But currently I suspect this to be a bug in the DirectSound? audio drivers, which means it is hard for us to do much about it.

comment:3 Changed 6 years ago by reimar

  • Cc qweac01@… added

comment:4 Changed 6 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

As mentioned I can't test it, but I added a workaround in r35563 that probably will be good enough.
Still will be slightly better with drivers that report the status correctly though.

comment:5 Changed 6 years ago by qweac01@…

Indeed in the wrong file playback was guilty -ao dsound. There is not a new build, checked in Fedora 17 RFRemix on MPlayer Sherpya-SVN-r33574-4.2.5

wine cmd
mplayer.exe -ao dsound 1.flac

#File is not fully reproduced

mplayer.exe -ao win32 1.flac
mplayer.exe -ao sdl 1.flac

#File is reproduced in full

Note: See TracTickets for help on using tickets.