Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#211 closed defect (invalid)

Documentation lists option with -, but -- required

Reported by: askwar@… Owned by: diego@…
Priority: normal Component: DOCS
Version: unspecified Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

[17:35:27 alexander@server:~/Programme/src/mplayer/MPlayer-20050118] $ ./mplayer
-dvd-device
MPlayer dev-CVS-050118-06:00-3.4.3 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Unknown option on the command line: dvd-device
[17:35:31 alexander@server:~/Programme/src/mplayer/MPlayer-20050118] $ ./mplayer
--dvd-device
MPlayer dev-CVS-050118-06:00-3.4.3 (C) 2000-2005 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

You added '--' but no filenames presented!

As you can see, I first entered "-dvd-device", because that's the way it is
listed in the man page and all the other documentation (like the web page and
such). mplayer, however, requires that the option be specified with two dashs;
ie. --dvd-device. That's true not only for "dvd-device" but for a number of
other options as well.

I verified that this bug is current, by downloading the daily CVS snapshot from
2005-01-18.

Change History (4)

comment:1 Changed 15 years ago by diego@…

  • Resolution set to invalid
  • Status changed from new to closed

Nonsense. You have a problem with your local configuration. If you don't
believe me, just read the source.

comment:2 Changed 15 years ago by reimar

No, -dvd-device is the correct syntax. If it doesn't work, your MPlayer version
was compiled without DVD support. --dvd-device is not supposed to work!

comment:3 Changed 15 years ago by askwar@…

  • Resolution invalid deleted
  • Status changed from closed to reopened

(In reply to comment #1)

Nonsense. You have a problem with your local configuration.

What are you talking about?

If you don't
believe me, just read the source.

Fine. Then the bug is not in the documentation but in the source. How do you
explain the output I pasted in the report?

comment:4 Changed 15 years ago by diego@…

  • Resolution set to invalid
  • Status changed from reopened to closed

Your MPlayer version is obviously compiled without DVD support. Do NOT reopen
this bug again --> INVALID.

Note: See TracTickets for help on using tickets.