Opened 7 years ago

Closed 6 years ago

#2125 closed defect (fixed)

lavc audio corrupted

Reported by: dinolib@… Owned by: reimar
Priority: normal Component: mencoder
Version: HEAD Severity: normal
Keywords: Cc:
Blocked By: Blocking:
Reproduced by developer: no Analyzed by developer: no

Description (last modified by reimar)

I use mencoder via PMS to encode multimedia files to PS3 since 2 years.

After an mencoder update I get broken audio: just noise.
Also latest svn compiled version (r35738) get the same result.

Here is a typical command line:

mencoder -ss 0 /home/dinoctest.avi -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=libmp3lame:abitrate=448:threads=2:keyint=4:vqscale=1:vqmin=2 -subdelay 20000 -ofps 25 -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o /tmp/test.mpg

acodec could be both libmp3lame or ac3.
Input file is a xvid+mp3 video (tried with many different files).

Change History (3)

comment:1 Changed 7 years ago by dinolib@…

Additional tests:
35127 works
35624 don't

comment:2 Changed 7 years ago by dinolib@…

It seems that the audio stream is not noise but just very very fast.

comment:3 Changed 6 years ago by reimar

  • Analyzed by developer unset
  • Description modified (diff)
  • Reproduced by developer unset
  • Resolution set to fixed
  • Status changed from new to closed

I missed this, it should be a duplicate of #2094, which was fixed in r36431.
What doesn't quite match up is that #2094 was caused by an FFmpeg update, so it should not be connected to a specific MPlayer version.

Note: See TracTickets for help on using tickets.