Opened 6 years ago

Closed 6 years ago

#2128 closed defect (fixed)

When fast forward RMVB files, audio output stop working

Reported by: dalanmao89@… Owned by: reimar
Priority: normal Component: ao
Version: unspecified Severity: normal
Keywords: Cc: cehoyos
Blocked By: Blocking:
Reproduced by developer: Analyzed by developer:

Description

When I used the left arrow key to fast forward a RMVB file, there is suddenly no output. I am an ArchLinux? user. After I upgrade from mplayer-35421-2 to mplayer-35915-1 and mplayer-35920-1 (they are dependent on x264-20130206-1), I found that when I fast forward a RMVB file, I can see the video but I can't hear the output. So I have to downgrade back to mplayer-35421-2 in order to play RMVB properly.

Change History (3)

comment:1 Changed 6 years ago by cehoyos

  • Cc cehoyos@… added

Please provide a sample.

comment:2 Changed 6 years ago by dalanmao89@…

Dear MPlayer Developers,

Sorry about filing an inaccurate bug report. Well, mplayer can play RMVB files without problems. The problem is that in new versions (post Jan 2013 versions?), when I forwarded using rightarrow key, there was a 3 to 5 seconds pause/delay in audio, therefore creating a false impression in me that there was a problem with audio output.

However, in the older version of mplayer (pre year 2013), the response in instantaneous, there will be no sound delay.

I have uploaded (using ncftpput) a sample RMVB which I played which has the audio-delayed which I mentioned above to ftp://upload.mplayerhq.hu/MPlayer/incoming, it is called *liaohaohui-mv.rmvb*. Is this a new audio-video synchronisation algorithm in mplayer's engine which caused the audio-delay?

comment:3 Changed 6 years ago by reimar

  • Resolution set to fixed
  • Status changed from new to closed

That file is very badly interleaved, I suspect something must have gone wrong in producing it.
Still, at least this specific file should be fixed in r35986.

Note: See TracTickets for help on using tickets.